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1. Introduction to Kernel for Linux

Welcome to the user manual for Kernel for Linux, which guides you on how the software recovers, files and 
folders from deleted, damaged, or corrupted Linux partitions. This user manual comprises step by step 
guidelines on using Kernel for Linux. 

1.1  Using this Manual 

This user manual is intended to guide users on using Kernel for Linux. We suggest that first time users 
should read this user manual completely and carefully before proceeding to use the software. However, if 
you are an experienced user, you can use the table of contents to find out information pertaining to the 
tasks that you need to perform by using Kernel for Linux. 

You can use the table of contents to navigate through different sections of this user manual. The table of 
contents lists all the sections that are contained in this user manual in chronological order. The user 
manual comprises the following sections: 

 Introduction

 Getting Started

 Software Interface

 Recovering Deleted Files

 Recovering Missing Partitions

 Customizing Recovered Files

 Recovery Resuming

 Full Version

 Support

 Troubleshooting

 Legal Notices

Certain abbreviations have been used throughout this manual. For clear understanding of the contents of 
this user manual, please go through the list of abbreviations, mentioned below, before reading the manual. 

1.1.1 List of Abbreviations 

MS: Microsoft 

RAM: Random Access Memory 
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MB: Mega-Byte 

GB: Giga-Byte 

1.2 About Kernel for Linux 

Kernel for Linux is a software utility developed for data recovery from hard disk and other storage media. It 
recovers Linux operating system data, lost or damaged due to following reasons: 

 Group Descriptor Block corruption

 Damaged Super Block or Inode Table

 Partition structures are damaged or deleted

 Improper System Shutdown

 File Deletion

Kernel for Linux can recover files and folders from disks on which the following components have become 
corrupted (or even if they are completely missing): 

 Partition table (main or extended)

 Boot Sectors (sometimes called "BIOS Parameter Block" or BPB)

 File Allocation Table

 Root Folders

 Master File Table

1.3 Salient Features 

Kernel for Linux - data recovery software provides following features: 

 Recovery if the partition has been deleted.

 Data recovery of missing files and folders.

 Volume recovery on Linux systems with damaged Super Block

 Volume recovery on Linux systems with damaged Leaf Node

 Volume recovery on Linux systems with damaged Journal

 Full support for IDE, EIDE, SCSI and SATA, PAN, ZIP drives.
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1.4 Who Should Use this Software? 

The competence of Kernel for Linux to recover partitions makes it appropriate for use by professionals, 
organizations and individuals, who have lost their important data stored in Linux Operating System. Kernel 
for Linux is suitable for users, who are striving to recover files and folders from disks which contain 
components like partition table, boot sectors, file allocation tables, root folders or master file table. 
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2. Getting Started

Now that you have understood the features and potential of Kernel for Linux, you are ready to get hands 
on experience of the software. To start recovery of partition of Linux Operating System, first of all you will 
need to need to download and install this software. 

It is strongly recommended that before installing Kernel for Linux, you should go through the installation 
pre-requisites for the software to ensure that your computer is appropriately configured to run the 
software. 

2.1 Installation Pre-requisites 

Kernel for Linux - data recovery software works on all Linux-based computers. Following are detailed 
minimum system requirements for the host computer: 

2.1.1 Operating Systems 

Windows 95, 98, 2003, and ME, NT, 2000, XP, Vista 

2.1.2 Memory (RAM) 

At least 64 megabytes (the more the better) 

2.1.3 CPU Processor 

Pentium II 400 MHz 

2.1.4 Available Space on the Good Device 

Enough space to save the recovered data; for example, if you expect to recover 40 MB lost data, the Good 
Device should have at least 40 MB free space (and even more if you plan to take the Host Computer as 
the Good Device) 

2.2 Downloading Kernel for Linux for the First Time 

After checking your computer with the prescribed system requirements for Kernel for Linux, you can 
download and install the software on your computer. You can buy the full version of the software from any 

one of our authorized resellers– Element5, Asknet and 2CO. 

If you want to try using Kernel for Linux before buying it, you can download the evaluation version from the 
following link: 

https://www.nucleustechnologies.com/Linux-Data-Recovery-Software.html

2.3 Install Kernel for Linux 

After downloading the installer file for Kernel for Linux, you can install the software by running the file. To 
install Kernel for Linux: 

https://www.nucleustechnologies.com/Download-Linux-Data-Recovery-Software.php
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1. Double-click the Kernel for Linux installer. Follow the on-screen instructions.

The Setup Installation Complete screen will be displayed. 

2. Click Finish to launch the software.

2.4 Start Kernel for Linux 

To start Kernel for Linux: 

Click the Start  All Programs Kernel for Linux 

Alternatively, you can launch Kernel for Linux by double-clicking the shortcut icon available on the Desktop 
and Quick Launch icon. 

2.5 Uninstall Kernel for Linux 

You may need to uninstall and re-install Kernel for Linux. To uninstall Kernel for Linux: 

1. Click the Start  All Programs Kernel for Linux Uninstall Kernel for Linux

A warning message will be displayed. 

2. Click Yes to uninstall Kernel for Linux.

 Before proceeding to uninstall Kernel for Linux, you must ensure that the software is 
not running on your system. 

You can alternatively uninstall Kernel for Linux from the Control Panel by performing the following steps: 

1. Click the Start Menu  Control Panel and then double click the Add or Remove Programs icon.

2. Select Kernel for Linux and click Remove.

A warning message will be displayed. 

3. Click Yes to uninstall Kernel for Linux.
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3. Software Interface

Now that Kernel for Linux has been installed on your computer, you can start using the software after 
getting acquainted with the software interface. 

3.1 Menu-bar 

The menu-bar of Kernel for Linux comprises three main menus – Recovery, View, Tools and Help. 

3.1.1 Recovery Menu 

The Recovery menu comprises four menu items. 

Figure 3.1: Recovery Menu 

Menu items in the Recovery menu: 

Field Name Field Description 

Recover 
Selected 

Recovers the selected files 

Recover All Recovers all files 

Save Recovery 
Snapshot 

Saves the scan information about the file(s) and folder(s) found in 
recovery process 

Load Recovery 
Snapshot 

Loads the saved scanned information 

Exit Close the software 

3.1.2 View Menu 

The View menu comprises three menu items. 
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Figure 3.2: View Menu 

Menu Items in the View menu: 

Field Name Field Description 

Icons Displays the file(s) and folder(s) in windows 
standard small icon view style 

List This option will display the file(s) and folder(s) in 
windows standard list view style 

Details View default display style for files and folders 

3.1.3 Tools Menu 

The Tools menu comprises three menu items. 

Figure 3.3: Tools Menu 

Menu items in the Tools menu: 

Field Name Field Description 

Find Files Searches for a particular file or file type in the data found 

File Filters Adds filters to files 

Settings Configures the software settings 
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Drive Information Displays the information about the file system being 
recovered 

Live Update Updates the current software version 

3.1.4 Help Menu 

The Help Menu comprises three menu items: 

Figure 3.4: Help Menu 

Field Name Field Description 

Contents Displays the user manual of Kernel for Linux 

Buy Online Purchase software online from website 

About KernelApps Displays version related information of the software 

3.2 Tool-bar 

The tool-bar in Kernel for Linux is displayed below the menu-bar. The tool-bar provides a convenient and 
user-friendly method to perform certain actions that can also be performed by using the menu-bar. Read 
the information in the table below to find out about the tool-bar buttons: 

Button Button Name Button Description 

Recover 
Selected 

Recovers selected files 

Recover All Recovers all files 
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Save Recovery 
Snapshot 

Saves the scan information about the file(s) and 
folder(s) found in recovery process 

Load Recovery 
Snapshots 

Loads the scanned information 

Find Files Searches for a particular file or file type in the data 
found 

Settings Configures the software settings 

Live Update Updates the current software version 



© KernelApps Private Limited

4. Recovering Deleted Files

Now that you have complete familiarity of the user interface of Kernel for Linux, you are ready to start with 
the recovery process. This section deals with deleted files and allows the user to undelete them for 
recovering deleted files, these steps needs to be performed: 

1. In the main window of Kernel for Linux – data recovery software, it shows all the detected Hard Disks
in the left pane of the main window.

Figure 4.1: Main Window 

2. Choose Physical Drive where all your deleted files are located, select "Use Partition Table" and click
Next button.
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Figure 4.2: Select Physical Drive 

3. Now it will show all the available partitions in the selected storage device in the left pane of the
software. Choose the Logical Drive or Partition that contains Recoverable data and click Next to
proceed.

4. Kernel for Linux will ask you to select the mode of recovery, select the recovery mode and click OK.
Once recovery mode is selected, Kernel for Linux will start the recovery process.
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Figure 4.3: Select Mode of Recovery 

5. After completion of the recovery process, Kernel for Linux will display all the file(s) and folder(s) found
in the selected partition.
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Figure 4.4: Files and Folders found in Selected Partition 

6. Select the deleted files and click Recover All or Recover Selected button from the toolbar to save the
recovered files to the desired location.
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5. Recovering Missing Partitions

1. In the main window of Kernel for Linux – data recovery software, it shows all the detected drives in the
left pane of the main window.

Figure 5.1: Main Window- Kernel for Linux 

2. Choose Physical Drive where all your deleted or missing partitions are located, select "Search
Partition", edit the start and end sector to scan and click Next button.
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Figure 5.2: Select Physical Drive 

3. After this process, Kernel for Linux will list all the partition(s) found in left pane of the window. Then it
will show you all the available partitions in the selected storage device in the left pane of the window.

Choose the Logical Drive or Partition that contains Recoverable data and click Next button to proceed.
Then Kernel for Linux will ask you to select the mode of recovery.
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Figure 5.3: Select Recovery Mode 

4. After choosing the mode of recovery, Kernel for Linux will start the recovery process. After completion
of the recovery process, Kernel for Linux will display all the file(s) and folder(s) found in the selected
partition.
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Figure 5.4: Preview of Recovered Files and Folders 

5. Select the deleted files and Click Recover All or Recover Selected button from the toolbar to save
the recovered files to the desired safest location.
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6. Customizing Recovered Files

 Kernel for Linux data recovery software provides you with the option to configure the software to ease the 
process of recovery. It provides the various options to have a control over the whole recovery process. To 
configure the software you can follow these steps: 

Click Tool Menu > Settings or click Setting button from the Toolbar, Kernel for Linux displays the screen 
where you need to select the options to configure the software. 

Figure 6.1: Recovery Setting Window 

Sectors to read in single attempt 

This is the setting for the number of sector(s) to read in a single attempt. Increasing this value will make 
the software run faster. But in general this value should be set to a lesser value in the disks with bad 
sectors; you can increase this value for disks with good physical condition for faster recovery. 

Settings of duplicate file(s) 
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This is the setting for duplicate file(s); there may be a situation that the folder where you are recovering the 
files may contain file(s) with the same name. 

 By default the selected option is Rename Duplicate File(s) , so it renames the file(s)

 By selecting Overwrite Duplicate File(s), it overwrites the existing file(s) with the new file(s)

 By selecting Skip Duplicate File(s), it will not save those duplicate file(s)

Settings for Deleted File(s) 

This option gives you control over the recovery of deleted file(s). 

 By default the selected option is Include Deleted file(s), at the time of copying the data it includes
deleted file(s).

 By selecting Recover only Deleted File(s), it will copy only deleted file(s).

 By selecting Exclude Deleted File(s), it will not copy deleted file(s).

Settings for Bad sectors 

Number of retries on bad sector(s): This is the option that how many times the software will try to read a 
sector if the sector is not readable in single attempt. 
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7. Save Recovery Snapshot

Kernel for Linux provides the option to resume the recovery; it can load a saved recovery state file to 
resume a previous recovery session. There are times when a scan seems to take forever. They can last 
for hours, sometimes days depending upon the size of the drive as well as the damage to the file system. 
In order to avoid rescanning, you can use the Save Recovery Snapshot. 

1. Click Recovery menu > Save recovery snapshot or click Save recovery snapshot button from
toolbar. A screen to save the recovery snapshot will appear.

2. Select the desired location and save your recovery snapshot to that location.

3. To resume recovery, use Load Recovery Snapshot when you have selected storage device.

4. Click Recovery Menu > Load Recovery Snapshot or click Load Recovery Snapshot button
from toolbar, then it displays a screen to select the location for loading last recovery summery.

5. Select the desired location and your last recovery summary.
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8. Full Version

Although you can use Kernel for Linux evaluation version for free and experience the working of the 
software, there are certain features that are not available in the evaluation version. 

8.1 Requirement of Full Version 

By using the evaluation version of Kernel for Linux, you can repair corrupt, damaged and deleted; Linux 
partitions. However, you cannot save the recovered data. 

You will need to buy the full version of the software to save the recovered data. 

8.2 Purchasing Full Version 

You can buy the full version of Kernel for Linux from any one of our authorized resellers – Element5, 
Asknet and 2CO. 

As soon the purchase transaction with our resellers gets completed, our sales team will send you an email 
comprising the URL to download the full version of Kernel for Linux and activation details of the software. 
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9. Support

We have an extensive and efficient support system in place to assist our customers with all issues related 
to using Kernel for Linux. The software comes with an embedded help manual that can be accessed 
by clicking HelpSoftware Help in the menu-bar. You can also press the F1 key on the keyboard of 
your computer to access the embedded help of Kernel for Linux. 

We also have live support wherein you can chat with our software experts at 

https://www.nucleustechnologies.com/supportcenter/

To talk on phone with our software experts call: 

Help line:  

+91-9818725861

1-866-348-7872 (Toll Free for USA/CANADA)

You can also email us about your queries at; 

sales@nucleustechnologies.com for Sales 

support@nucleustechnologies.com for Support 

contact@nucleustechnologies.com for General Queries 

https://www.nucleustechnologies.com/Animated_Demo_Linux.html
https://www.nucleustechnologies.com/supportcenter/
mailto:sales@nucleustechnologies.com
mailto:support@nucleustechnologies.com
mailto:contact@nucleustechnologies.com
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10. Troubleshooting

This section deals with your generic and specific queries pertaining to using Kernel for Linux. 

10.1 Common Issues 

Why does Kernel for Linux have limitations in evaluation copy? 

The free evaluation version of Kernel for Linux is intended to enable you to experience the capabilities of 
the software. You will need to buy the software to save the recovered data. 

10.2 Frequently Asked Questions 

How to Buy Kernel for Linux? 

You can buy Kernel for Linux online at https://www.nucleustechnologies.com/Buy-Linux-Data-
Recovery-Software.php  

I have lost my full version for Kernel for Linux. Can you help me? 

Please email us at sales@nucleustechnologies.com. Please include your name, address, email address, 
and order confirmation number (if you have it). We will be happy to help you. 

https://www.nucleustechnologies.com/Buy-Linux-Data-Recovery-Software.php
https://www.nucleustechnologies.com/Buy-Linux-Data-Recovery-Software.php
mailto:sales@nucleustechnologies.com
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11. Legal Notices

This section comprises the legal specification about Kernel for Linux and the company KernelApps 
Private Limited

11.1 Copyright 

KernelApps Private Limited, KernelApps accompanied user manual and documentation are copyright of
KernelApps Private Limited, with all rights reserved. Under the copyright laws, this user manual cannot
be reproduced in any form without the prior written permission of KernelApps Private Limited. No
Patent Liability is assumed, however, with respect to the use of the information contained herein. 

© KernelApps Private Limited. All rights reserved.

11.2 Trademark 

KernelApps ® is a copyright work of KernelApps Private Limited

Windows 95®, Windows 98®, Windows ME®, Windows NT®, Windows 2000 Server®, Windows 2000 
Advanced Server®, Windows 2003 Server®, Windows XP®, Windows Vista, MS-DOS and Linux are 
registered trademarks of Microsoft Corporation and Linux Online, Inc. 

All other brand and product names are trademarks or registered trademarks of their respective companies. 

11.3 Disclaimer 

The Information contained in this manual, including but not limited to any product specifications, is subject 
to change without notice. KernelApps Private Limited provides no warranty with regard to this manual or
any other information contained herein and here by expressly disclaims any implied warranties of 
merchantability or fitness for any particular purpose with regard to any of the foregoing KernelApps 
Private Limited assumes no liability for any damages incurred directly or indirectly from any technical or
typographical errors or omissions contained herein or for discrepancies between the product and 
the manual. In no event shall KernelApps Private Limited, be liable for any incidental,
consequential special, or exemplary damages, whether based on tort, contract or otherwise, arising out 
of or in connection with this manual or any other information contained herein or the use there of. 

11.4 License Agreement 

Kernel for Linux Copyright © by KernelApps Private Limited

Your Agreement to this License 

You should carefully read the following terms and conditions before using, installing or distributing 
this software, unless you have a different license agreement signed by KernelApps Private Limited.
The terms and conditions of this License describe the permitted use and users of 



© KernelApps Private Limited

each Licensed Copy of Kernel for Linux. For purposes of this License, if you have a valid license, 
you have the right to use a single Licensed Copy of KernelApps.

Scope of License 

Each Licensed Copy of Kernel for Linux may either be used by a single person or used non-
simultaneously by multiple people who use the software personally installed on a single workstation. 
All rights of any kind in KernelApps, which are not expressly granted in this License, are entirely and
exclusively reserved to and by KernelApps Private Limited. You may not rent, lease, modify, translate,
reverse engineer, decompile, disassemble, or create derivative works based on, KernelApps, nor permit
anyone else to do so. You may not make access to KernelApps available to others in connection with a
service bureau, application service provider, or similar business, nor permit anyone else to do so. 

Warranty Disclaimers and Liability Limitations 

Kernel for Linux, and any and all accompanying software, files, data and materials, are distributed 
and provided AS IS and with no warranties of any kind, whether expressed or implied. In particular, there 
is no warranty for the quality of data recovered. You acknowledge that good data processing procedure 
dictates that any program, including KernelApps, must be thoroughly tested with non-critical data before
there is any reliance on it, and you hereby assume the entire risk of all use of the copies of 
KernelApps covered by this License. This disclaimer of warranty constitutes an essential part of this
License. In addition, in no event does KernelApps Private Limited authorize you or anyone else to
use Kernel for Linux in applications or systems where Kernel for Linux failure to perform can 
reasonably be expected to result in a significant physical injury, or in loss of life. Any such use is 
entirely at your own risk, and you agree to hold KernelApps Private Limited harmless from any and all
claims or losses relating to such unauthorized use. 

General 

This License is the complete statement of the agreement between the parties on the subject matter, 
and merges and supersedes all other or prior understandings, purchase orders, agreements 
and arrangements. This License shall be governed by the laws of the State of Delhi. Exclusive jurisdiction 
and venue for all matters relating to this License shall be in courts and for a located in the State of Delhi, 
and you consent to such jurisdiction and venue. There are no third party beneficiaries of any 
promises, obligations or representations made by KernelApps Private Limited herein.

Any waiver by KernelApps Private Limited of any violation of this License by you shall not constitute,
nor contribute to, a waiver by KernelApps Private Limited of any other or future violation of the same
provision, or any other provision, of this License. 


