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1. Introduction to Kernel for DBF

Welcome to the user manual for Kernel for DBF, the most effective and convenient File Repair Software
that recovers corrupted DBF database files corrupted due to unexpected system shutdown, virus attacks or
error reading media where documents are stored. This user manual comprises step by step guidelines on
using Kernel for DBF.

1.1 Using this Manual

This user manual is intended to guide users on using Kernel for DBF. We suggest that first time users
should read this user manual completely and carefully before proceeding to use the software. However, if
you are an experienced user, you can use the table of contents to find out information pertaining to the
tasks that you need to perform by using Kernel for DBF.
You can use the table of contents to navigate through different sections of this user manual. The table of
contents lists all the sections that are contained in this user manual in chronological order. The user
manual comprises the following sections:

e Introduction

e Getting Started

e Software Interface

¢ Repairing Corrupt DBF Files

e Customizing Repaired Files

e Saving Repaired Files

e Full Version

e Support

e Troubleshooting

e Legal Notices

Certain abbreviations have been used throughout this manual. For clear understanding of the contents of
this user manual, please go through the list of abbreviations, mentioned below, before reading the manual.

1.1.1 List of Abbreviations
MS: Microsoft
RAM: Random Access Memory

MB: Mega-Byte
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GB: Giga-Byte
1.2 About Kernel for DBF

Kernel for DBF — File Repair Software recovers data from corrupted DBF database files corrupted due to
unexpected system shutdown, virus attacks or error reading media where documents are stored.

During repair process, complete scan of the damaged databases is performed to locate and extract the
recoverable information. After complete scanning, the databases which are repairable are recovered and
copied in the used defined location. Kernel for DBF repairs corrupted DBF database files, damaged due to
following reasons and displays error messages such as:

e Bad sector in the disk

e Unexpected System Shutdown

e Virus Corruption

¢ Media Corruption

¢ Unrecognized Database Format

Kernel for DBF uses quick algorithm for searching and repairing corrupted database files and hence is a
fast, simple and easy to use DBF Database Repair Software, which helps you to recover data and repair
your corrupt database files in minutes.

1.3 Salient Features

Salient features of Kernel for DBF include:
e Repairs Corrupt DBF table
e Repair .DBF files with memo or binary data fields stored in DBT or FPT files
e Support for batch repairing of DBF files

e User friendly interface, no technical skills required

1.4 Who Should Use this Software?

The capability of Kernel for DBF to repair corrupt DBF files makes it appropriate for use by organizations
and individuals, who are worried due to the corruption of their DBF files. This corruption could have been
caused due to virus attacks, improper system shutdown, installation of unsupported software, etc.
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2. Getting Started

Now that you have understood the features and potential of Kernel for DBF, you are ready to get hands on
experience of the software. To start repairing DBF files, you will first need to download and install this
software.

It is strongly recommended that before installing Kernel for DBF, you should go through the installation
pre-requisites for the software to ensure that your computer is appropriately configured to run the
software.

2.1 Installation Pre-requisites

Following are detailed minimum system requirements for the host computer:

2.1.1 Hardware Requirements:

The hardware requirements for installing the software are as follows:
e Pentium Class Processor
e Minimum 64MB RAM (128 MB recommended)
e 10MB for software installation
2.1.2 Operating System Requirements
Supported Operating Systems:
e Windows Vista
e Windows XP
e Windows 2003
e Windows 2000
2.1.3 DBF Versions Requirements

e All versions of DBF database

2.2 Downloading Kernel for DBF for the First Time

After checking your computer with the prescribed system requirements for Kernel for DBF, you can
download and install the software on your computer. You can buy the full version of the software from any
one of our authorized resellers— Element5, Asknet and 2CO.

If you want to try using Kernel for DBF before buying it, you can download the evaluation version from the

following link:
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https://www.nucleustechnologies.com/Download-DBF-Database-Repair-Software.php

X You can repair .dbf files saved on your system by using the evaluation version of
Kernel for DBF; however, the repaired file will not be saved until you purchase the
full version of the software.

2.3 Install Kernel for DBF

After downloading the installer file for Kernel for DBF, you can install the software by running the file. To
install Kernel for DBF:

1. Double-click the Kernel for DBF installer. Follow the on-screen instructions.
The Setup Installation Complete screen will be displayed.

2. Click Finish to launch the software.

2.4 Start Kernel for DBF

To start Kernel for DBF:
Click the Start - All Programs >Kernel for DBF

Alternatively, you can launch Kernel for DBF by double-clicking the shortcut icon available on the Desktop
and Quick Launch icon.

2.5 Uninstall Kernel for DBF

You may need to uninstall Kernel for DBF. To uninstall Kernel for DBF:
1. Click the Start - All Programs >Kernel for DBF - Uninstall Kernel for DBF
A warning message will be displayed.

2. Click ‘“Yes’ to uninstall Kernel for DBF.

. Before proceeding to uninstall Kernel for DBF, you must ensure that the software is
not running in system background.

You can alternatively uninstall Kernel for DBF from the Control Panel by performing the following steps:
1. Click the Start Menu - Control Panel and then double click the Add or Remove Programs icon.
2. Select Kernel for DBF and click Remove.

A warning message will be displayed.

3. Click Yes to uninstall Kernel for DBF.
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3. Software Interface

Now that Kernel for DBF has been installed on your computer, you can start using the software after
getting acquainted with the software interface.

3.1 Menu-bar

The menu-bar of Kernel for DBF comprises three main menus — File, Tool, and Help.

3.1.1 File Menu

The File menu comprises four menu items.

@ AddFiles...
3¢ Remove All Files
ﬁ Remaove Selected Files

Exit

Figure 3.1: File Menu

Menu items in the File menu:

Add Files Adds the corrupted FoxPro Database files for repairing
Remove All Select to remove selected files from the list

Files

Remove Remove all the files from the list of files to be repaired

Selected Files

Exit Close Kernel for DBF

3.1.2 Tool Menu

The Tool menu comprises two menu items.

@) Setting
(§) Liveupdate

Figure 3.2: Tool Menu

Menu Items in the Tool menu:
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Setting Configures name of the repaired file

Live Update Updates the current software with the
available version in the Kernel server

3.1.3 Help Menu

The Help menu comprises three menu items.

2 Help
€ About Nucleus Kemel DEF...

{§) Software Home Page...

Figure 3.3: Help Menu

Menu items in the Help menu:

Help Displays help for the software
About Kernel DBF Shows the version and other information related to the
software
Software Home Page Opens the software home page
3.2 Tool-bar

The tool-bar in Kernel for DBF is displayed below the menu-bar. The tool-bar provides a convenient and
user-friendly method to perform certain actions that can also be performed by using the menu-bar. Read
the information in the table below to find out about the tool-bar buttons:

- Add Files Adds the corrupted FoxPro Database files for
__a repairing
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2. Repair Files Select to remove selected files from the list
«©
I l Save Files Saves Repaired Files

Setting Changes the prefix of the repaired file name
T Live Update Updates the current software with the
Q available version in the Kernel server

3.3 Status Bar

Status bar is displayed at the bottom of the software window. The text ‘Ready’ is displayed on the status
bar if Kernel for DBF is ready to be used. Status bar also displays the text ‘CAP’, ‘NUM’, ‘SCRL’ which
respectively correspond to the Caps Lock, Num Lock, and Scroll Lock keys on your keyboard. If any of
these keys are pressed, the color of the corresponding text will turn blue/black.

ln..p, CAP NUM 1O I

Figure 3.4: Status Bar

. ',/'
Kernel <y

© KernelApps Private Limited for FoxPro



4. Repairing Corrupt DBF Files

Now that you have complete familiarity of the user interface of Kernel for DBF, you are ready to repair
corrupt DBF files.

To repair DBF files:

1. Launch Kernel for DBF.

"8 Mt b i o] T

P Task  Hel
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Pegur welene e mm repale | Uisieg Bopery e enan
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Figure 4.1: Main Window

2. Click Add Files button from toolbar or click file menu, choose Add file to add corrupted files in the list.
A dialogue box to open files will appear.
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Select corrupted file to repair...

?X)

Lack i [_; AE2021 v Q2 e m
: :
||®]acmasT.0EE  |®]BROKPAY.DEE  |¥|COMPSTAT.DEF %) GDRET.DEF
. .
|#]APMCDOC.DBF || CALCMAST.DEF %] COPGMAST.DEF || GENERAL,DEF
%] APMCTRAN.DEF | %] CATEGORY.DEF | %] COPGTRAN.DEF  |#] GODOWN.DEF
|#]BANKRECO.DEF  |#]CBTRAN.DEF  |#|CREDITOR.DEF  [#] INEXP.DEF
||#]ERANDDET.DBF || CHRETDET.DEF  |%|DEETOR.DEF | ] INTBANK.DEF
||#]eroKER.DEF | %] CODE.DEF |%|ExTBAMK.DEF | #]ITEM.DEF
|
| >
File narne: | I Open ]
Files of type: | DBF Files[™ db) | Cancel |

Figure 4.2: Select Corrupt File to Repair

3. Click Open to add the selected files in the list of file(s) to be repaired or click Cancel to abort the
situation. Once the corrupted files are selected for repairing, they will get listed on the software screen.

4. If you have added any unwanted file, then you can also remove those file(s) by using Remove All files

button and Remove Selected Files button.

5. Select the file(s) that you want to repair and click Next button or click Repair Files Button from the

toolbar.

6. A dialogue box to select the repair mode will appear. Select the appropriate mode and click OK.

. Selection of repair mode depends upon the version of DBF database file.

After selecting the files to be repaired, Kernel for DBF begins its repairing process and shows the details

of the corrupted file.
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Figure 4.3: Repairing Process Status

7. Kernel for DBF also allows you to see preview of the repaired files. Once repairing process is
complete, click Next to see the preview for the selected repaired file.
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Figure 4.4: Preview of Repaired Files

8. Click Save Files button for saving or copying the recovered files.
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5. Customizing Repaired Files

Kernel for DBF provides you with the option to personalize the repaired file name. To configure the file
name of the repaired files you can follow these steps:

e Click Tool Menu > Setting or click Setting button from the Toolbar. A dialogue box named
Settings will appear.

Settings

File Marme Prefix |

Figure 4.5: Define Repaired File Setting

¢ In that dialogue box, type the desired name that you want to give to your repaired file, then click
OK or select Cancel to abort the situation.
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6. Saving Repaired Files

To save the repaired file, you can follow these steps:

o After repairing of corrupted files, Kernel for DBF will display the details of repaired files. Click Save
Files button from the toolbar; it will display Browse For Folder Screen.

Browse for Folder

Please select the path ko Save the files

=] [;5 Deskkop

,_1:'1 My Documents

?} Py Computer

[+ g Local Disk (22

¥ g Local Disk (D)

[+ g Local Disk (B —
[ b DYDJCO-RY Drive (F:)
e Control Panel
® 4 Mokia Phane Browser
# {7 Shared Documents
H ) anu's Documents

:i"i _J Plus Blabiemel Dla-ae

£ | b

-
[

o

Ik ] [ Cancel

Figure 4.6: Select Folder to Save Files

e Choose the desired location and click OK to save the files.

Kernel ,/3

© KernelApps Private Limited for FoxPro



7. Full Version

Although you can use Kernel for DBF evaluation version for free and experience the capabilities of the
software, there are certain features that are not available in the evaluation version.

7.1 Requirement of Full Version

By using the evaluation version of Kernel for DBF, you can repair corrupt DBF files but cannot save the
repaired files. You will need to buy the full version of the software to save the repaired files.

7.2 Purchasing Full Version

You can buy the full version of Kernel for DBF from any one of our authorized resellers — Element5,
Asknet and 2CO.

As soon the purchase transaction with our resellers gets completed, our sales team will send you an email
comprising the URL to download the full version of Kernel for DBF and activation details of the software.
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8. Support

We have an extensive and efficient support system in place to assist our customers with all issues related
to using Kernel for DBF. The software comes with an embedded help manual that can be accessed
by clicking Help>Software Help in the menu-bar. You can also press the F1 key on the keyboard of
your computer to access the embedded help of Kernel for DBF.

You can access the online help for Kernel for DBF at https://www.nucleustechnologies.com/
Online-Helps.html

View Animated Product demo of the software at

https://www.nucleustechnologies.com/dbf/animateddbf.html

We also have live support wherein you can chat with our software experts at
http://www.nucleustechnologies.com/supportcenter/.

To talk on phone with our software experts call:

Help line:

+91-9818725861
1-866-348-7872 (Toll Free for USA/CANADA)
You can also email us about your queries at;

sales@nucleustechnologies.com for Sales

support@nucleustechnologies.com for Support

contact@nucleustechnologies.com for General Queries
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9. Troubleshooting

This section deals with your generic and specific queries pertaining to using Kernel for DBF.

9.1 Common Issues

Why does Kernel for DBF have limitations in evaluation copy?

The free evaluation version of Kernel for DBF is intended to enable you to experience the capabilities of
the software. You will need to buy the software to save the repaired files.

9.2 Frequently Asked Questions

How to Buy Kernel for DBF?

You can buy Kernel for DBF online at https://www.nucleustechnologies.com/Buy-DBF-Database-
Repair-Recovery-Software.php

| have lost my full version for Kernel for DBF. Can you help me?

Please email us at sales@nucleustechnologies.com. Please include your name, address, email address,
and order confirmation number (if you have it). We will be happy to help you.
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10. Legal Notices

This section comprises the legal specification about Kernel for DBF and the company KernelApps
Private Limited

10.1 Copyright

KernelApps Private Limited, Kernel accompanied user manual and documentation are copyright
of KernelApps Private Limited, with all rights reserved. Under the copyright laws, this user manual
cannot be reproduced in any form without the prior written permission of KernelApps Private
Limited. No Patent Liability is assumed, however, with respect to the use of the information contained
herein.

© KernelApps Private Limited. All rights reserved.
10.2 Trademark

Kernel ® is a copyright work of KernelApps Private Limited

Windows 95®, Windows 98®, Windows ME®, Windows NT®, Windows 2000 Server®, Windows 2000
Advanced Server®, Windows 2003 Server®, Windows XP®, Windows Vista, and MS-DOS are registered
trademarks of Microsoft Corporation.

All other brand and product names are trademarks or registered trademarks of their respective companies.

10.3 Disclaimer

The Information contained in this manual, including but not limited to any product specifications, is subject
to change without notice. KernelApps Private Limited provides no warranty with regard to this manual or
any other information contained herein and here by expressly disclaims any implied warranties of
merchantability or fithess for any particular purpose with regard to any of the foregoing KernelApps
Private Limited assumes no liability for any damages incurred directly or indirectly from any technical or
typographical errors or omissions contained herein or for discrepancies between the product and
the manual. In no event shall KernelApps Private Limited, be liable for any incidental,
consequential special, or exemplary damages, whether based on tort, contract or otherwise, arising out
of or in connection with this manual or any other information contained herein or the use there of.

10.4 License Agreement

Kernel for DBF Copyright © by KernelApps Private Limited
Your Agreement to this License

You should carefully read the following terms and conditions before using, installing or distributing
this software, unless you have a different license agreement signed by KernelApps Private Limited.
The terms and conditions of this License describe the permitted use and users of
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each Licensed Copy of Kernel for DBF. For purposes of this License, if you have a valid license, you
have the right to use a single Licensed Copy of Kernel.

Scope of License

Each Licensed Copy of Kernel for DBF may either be used by a single person or used non-simultaneously
by multiple people who use the software personally installed on a single workstation. All rights of any kind
in Kernel, which are not expressly granted in this License, are entirely and exclusively reserved to and by
KernelApps Private Limited. You may not rent, lease, modify, translate, reverse engineer,
decompile, disassemble, or create derivative works based on, Kernel, nor permit anyone else to do so.
You may not make access to Kernel available to others in connection with a service bureau,
application service provider, or similar business, nor permit anyone else to do so.

Warranty Disclaimers and Liability Limitations

Kernel for DBF, and any and all accompanying software, files, data and materials, are distributed
and provided AS IS and with no warranties of any kind, whether expressed or implied. In particular, there
is no warranty for the quality of data recovered. You acknowledge that good data processing procedure
dictates that any program, including Kernel, must be thoroughly tested with non-critical data before
there is any reliance on it, and you hereby assume the entire risk of all use of the copies of
Kernel covered by this License. This disclaimer of warranty constitutes an essential part of this
License. In addition, in no event does KernelApps Private Limited authorize you or anyone else to
use Kernel for DBF in applications or systems where Kernel for DBF failure to perform can reasonably be
expected to result in a significant physical injury, or in loss of life. Any such use is entirely at your own risk,
and you agree to hold KernelApps Private Limited harmless from any and all claims or losses
relating to such unauthorized use.

General

This License is the complete statement of the agreement between the parties on the subject matter,
and merges and supersedes all other or prior understandings, purchase orders, agreements
and arrangements. This License shall be governed by the laws of the State of Delhi. Exclusive jurisdiction
and venue for all matters relating to this License shall be in courts and for a located in the State of Delhi,
and you consent to such jurisdiction and venue. There are no third party beneficiaries of any
promises, obligations or representations made by KernelApps Private Limited herein.

Any waiver by KernelApps Private Limited of any violation of this License by you shall not constitute, nor

contribute to, a waiver by KernelApps Private Limited of any other or future violation of the same
provision, or any other provision, of this License.
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