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1. Introduction to Kernel SQL Backup Recovery

Welcome to the user manual of Kernel SQL Backup Recovery, a powerful backup recovery tool to restore
corrupted or healthy SQL backup data easily. This user manual comprises step-by-step guidelines on using Kernel
SQL Backup Recovery tool.

1.1 Using this Manual

This user manual is intended to guide users on using Kernel SQL Backup Recovery software. We suggest that first
time users should read this user manual completely and carefully before proceeding to use the software.
However, if you are an experienced user, you can use the Table of Contents to find out information about the
tasks that you need to perform while using Kernel SQL Backup Recovery software.

You can use the Table of Contents to navigate through different sections of this user manual. The Table of
Contents enlists all the sections contained within this user manual in chronological order. This user manual
comprises following sections

e Introduction

e  Getting Started

e Software Interface

e Using Kernel SQL Backup Recovery
e Conclusion

e Support

e Copyright

1.2 About Kernel SQL Backup Recovery

Kernel SQL Backup Recovery is an eminent recovery solution and an ideal choice for those who are looking
forward to restoring their damaged or corrupt SQL backups. The software is equipped with QFSCI algorithm to
help the user perform fast and effective SQL backup recovery. SQL backup recovery software restores database
files from healthy or corrupt backup files along with objects like tables, views, triggers, stored procedures,
constraints, default constraints, indexes, rules, user defined functions & user defined data types.

This allows the users to query databases and fetch data information from previously formed databases. Many
operations including add, delete, modification of records and more can be performed on data using SQL queries.
When SQL database files get lost, corrupt or damaged, then restoring data from backup files becomes important.

Kernel SQL Backup Recovery is an effective software that helps you to successfully recover partly damaged
backup files. The software rebuilds batch automatically so that user can work on the database again. Also, the
software is capable of restoring the data to the working SQL database efficiently while the SQL Server is running.
This particular feature of Kernel SQL Backup Recovery tool makes it stand apart from the rest.
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Kernel SQL Backup Recovery is available as an evaluation version to let users analyze its capabilities and accuracy
of backup database recovery before deciding to purchase full version. Fully-functional free trial version works
exactly similar to that of the full version but has a limitation that it let users to Preview the recovered backup data
but does not allow to save at the destination. Purchase full version of Kernel SQL Backup Recovery in order to
save the recovered SQL backup database objects to live SQL Server and Batch File.

1.3 Salient Features
Salient features of Kernel SQL Backup Recovery tool include:
e Instantly recovers SQL backups with zero-error possibility
e User-oriented interface for easy and convenient use
e Smoothly restores data on LIVE SQL server
e Restores the backup files efficiently

e Flawlessly extracts entire data including tables, views, triggers, stored procedures, constraints, default
constraints, indexes, rules, user-defined functions & user-defined data types

e Preserves structure and properties of recovered objects

e Supports UNICODE characters for recovery

e Effectively scans and recovers data from large-sized SQL databases

e Free technical support availability 24*7

e Comes with free evaluation copy to offer complete insights about the tool's performance
e License validity of the tool lasts for a lifetime once purchased

e Compatible with different versions of MS SQL Server- 2000, 2005, 2008, 2008 R2, 2012, 2014, 2016 and
2017.

2. Getting Started

Now that you have understood the features and potential of Kernel SQL Backup Recovery, you are ready to get a
hand on experience of the software. To start recovery of SQL Server Backup data, you will first need to download
and install this software.

It is strongly recommended that before installing Kernel SQL Backup Recovery tool, you should go through the
installation pre-requisites for the software to ensure that your computer is appropriately configured to run the
software.

2.1 Installation Pre-requisites

Following are the basic system pre-requisites in order to perform successful recovery of SQL Server Backup
database using Kernel SQL Backup Recovery:
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2.1.1 Hardware Requirements:
The hardware requirements for installing the software are as follows:
e Pentium Class Processor
e 64 MB RAM (128 MB Recommended)
e 10 MB free space for Software installation

e Disk Space - Enough space to save the results

2.1.2 Software Requirements:

Supported MS Windows Operating System: Windows 10, Windows 8.1, Windows 8, Windows 7,
Windows Vista, Windows XP, Windows Server 2000, Windows Server 2003, Windows Server 2008,
Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, Windows Server 2016,
Windows Server 2017.

Supported MS SQL Server versions: SQL Server 2000, SQL Server 2005, SQL Server 2008, SQL Server
2008 R2, SQL Server 2012, SQL Server 2014, SQL Server 2016, SQL Server 2017.

2.2 Downloading Kernel SQL Backup Recovery for the First Time

After checking your computer with the prescribed system requirements for Kernel SQL Backup Recovery, you can
download the evaluation version of the software on your computer using the following link:

https://www.nucleustechnologies.com/sqgl-backup-recovery/

NOTE: The free trial version of Kernel SQL Backup Recovery helps to Preview recovered SQL
Backup data. To save recovered SQL backup database objects, purchase the full version of
the software.

2.3 Install Kernel SQL Backup Recovery

After being familiar with the software overview, key features, and system requirements let us install the software.
However, before installing the software make sure that the software installer file is available on your computer. If
the file is not available on vyour computer then you can download the file from our website-
https://www.nucleustechnologies.com/sql-backup-recovery/

After you have downloaded the installer file, execute the following steps to install the software:
1. Double-click the Kernel SQL Backup Recovery installer file.

2. Follow the on-screen instructions. When the installation process completes “Setup Installation Complete”
message appears on the software installation screen.

3. Click the Finish button to launch the software.
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To start Kernel SQL Backup Recovery software:
e  (Click Start > All Programs > Kernel SQL Backup Recovery

Alternatively, you can launch Kernel SQL Backup Recovery by double-clicking the shortcut icon available on the
desktop and Quick Launch icon.

You can uninstall the Kernel SQL Backup Recovery software from your computer system by using one of the
following two methods:

= Uninstall from Windows Start Menu

=  Uninstall from Control Panel

NOTE: Before proceeding to uninstall Kernel SQL Backup Recovery, you must ensure that the
software is not running.

Uninstall from the Windows Start menu
Execute the following steps to uninstall Kernel SQL Backup Recovery from Windows Start menu:

1. Click Start > All Programs > Kernel SQL Backup Recovery > Uninstall Kernel SQL Backup Recovery. A warning
message before un-installing the software will be displayed on the screen.

2. Click the Yes button to uninstall the software.
3. Click the OK button.
Kernel SQL Backup Recovery is successfully uninstalled from your computer system.
Uninstall from Control Panel
Execute the following steps to uninstall Kernel SQL Backup Recovery from Control Panel:
1. Click Start -> Control Panel. The Control Panel window appears.

2. Double-click the Add or Remove Programs icon. A list of the programs installed on your computer
appears.

3. Select Kernel SQL Backup Recovery and click the Remove button. A warning message before un-installing
the software will be displayed on the screen.

4. Click the Yes button to un-install the software.
5. Click the OK button.

Kernel SQL Backup Recovery is successfully uninstalled from your computer system

JKERNEL /&
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3. Software Interface

Now that Kernel SQL Backup Recovery has been installed on your computer, you can start using the software
after getting acquainted with the software interface.

K|
File Tools Help 30L Backup Recovery @

@ % @ Please click the Browse button and select the SQL Backup file. ] Kernel

} SQL Backup Recovery

SQL Database Objects Select BAK Fil: | []

Select Temp File Path: ~ C:lUserstADMINL~1, TEX| AppDataiLocal Templ [:]

Select a recovery mode to recover SQL Backup Recovery

@ Standard Scan (Guick Pracess, Recommended)

(7) Advanced Scan (Slow Proccess but preferred when "Out of Memory” message appears)

Select SQL database version
fiuto detect database version { uncheck if you want to select manually )
Manually select database version
S0L Server 2000 database
0L Server 2005 database
0L Server 2008, 2008 RZ database
S0L Server 2012, 2014, 2016 ,2017 database

< Back [ hext » H Cancel ] "

Ready | CAP| NUM| SCRL|
Figure 3.1 Welcome Screen of Kernel SQL Backup Recovery

3.1 Menu bar

The menu bar of Kernel SQL Backup Recovery comprises three main menus — File, Tool, and Help.
3.1.1 File Menu

The File menu of Kernel SQL Backup Recovery appears as:

IKERNEL
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File | Tools Help

EZ  Add.

1
Save..

’1 Exit

Figure 3.2 File Menu

Following table enlists the options available in the File menu:

Add Select this option to locate the damaged SQL backup on your hard disk
Save Select this option to save the data so recovered from the SQL backup
Exit Select this option to close the software

3.1.2 Tool Menu
Tools menu of Kernel SQL Backup Recovery appears, as shown in the figure given below:

Toaols | Help
Cptions...

Figure 3.3 Tools Menu

Following table enlists the options available in the Tools menu:

Consider all pages as corrupted It is recommended to select this option as it is useful in
recovering data from heavily corrupted databases.

Save the tables without identity property Select this option if tables are not saving due to corrupted
data. Checking this option will allow saving the tables
without identity, you can set the identity of these tables
after recovery.

!’(ﬁ*}'!:i JO
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3.1.3 Help Menu

Help menu of Kernel SQL Backup Recovery appears, as shown in the figure given below:

Help |
@ | Kernel for S50L Backup Recovery

| Kernel for 0L Backup Recovery Homepage

- About Kernel for SCL Backup Recovery...

Figure 3.4 Help Menu

Following table enlists the options available in the Help menu:

Kernel SQL Backup Recovery Select this option to view Help manual of the software

Kernel SQL Backup Recovery Select this option to visit the website for know more about the
Homepage software

About Kernel SQL Backup Select this option to view version information and software
Recovery... support details of the software

3.2 Toolbar

Tool bar consists of buttons that work as short cuts for various options available in the main menus of Kernel SQL
Backup Recovery software. Following table enlists the buttons available on the Tool bar of the software:

Select this option to locate the damaged SQL

@l

backup file on your hard disk

% Select this option to save the data so recovered
from the SQL backup file

Select this option to view Help manual of the
software

[KERNEL
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4. Using Kernel SQL Backup Recovery

Kernel SQL Backup Recovery can be used to restore SQL backup data to two destinations — Live SQL Server and
Batch File.

4.1 Restore SQL Backup Files

Kernel SQL Backup Recovery is an ideal software that helps you restore objects from corrupt backups. No matter
what made your backup data corrupt or inaccessible, Kernel SQL backup recovery will recover your data easily
and quickly.

You can save the recovered objects in two different modes which are:
e SQL Server:

Using this option, the recovered objects can be saved on SQL Server directly, even if the Server is running. To save
the data on SQL Server:

1. Mention Server Name and Name of the database in Server Name and Database name fields respectively.
Do not provide name of existing database in Database name field. Create a new database in SQL Server
Management Studio and enter the name of new database in Database name field. However, existing
database name can also be provided but in case of existing database restored objects will get merged
with existing objects.

2. Select the Authentication option with which you wish to access the SQL Server i.e. Windows
Authentication or Server Authentication

To access SQL Server with Server Authentication, you need to enter User Name and Password in the respective
fields.

e Batch File (by SQL Scripts):

Using this option, you can save the batch file of the rebuilt SQL backup file database on a desired location. To save
the recovered backup file data, you need to browse the location using the Browse button. The data so recovered
is saved in separate script files at the desired location. Also, a script file (commit.bat) is also created that enables
the user to easily copy the recovered objects to a new database created on SQL Server. To copy recovered objects
to new database on SQL server:

1. GotoSQL Server Management Studio
2. Create a New Database
3. Double click on commit.bat
OR
(Run->cmd ) Change the path to recovered folder ( cd PathName)

4. Use following syntax:

IKERNEL Ad
KernelApps Private Limited umnscovmf



11

>commit.bat servername newcreateddatabase sqlserverusername sqlserverpassword

Press Enter key and all tables will be copied to the new created database.

4.1.1 Restore SQL Backup File to Live SQL Server

Kernel SQL Backup Recovery is an ideal software that helps you restore objects from corrupt backups. No matter
what made your backup data corrupt or inaccessible, Kernel SQL backup recovery will recover your data easily
and quickly. Follow the steps given below to repair SQL backups:

1. Select Start > All Programs > Kernel SQL Backup Recovery > Kernel SQL Backup Recovery to launch the
software. The software home window appears.

=]

File Tools Help SOL Backup Recowvery @
E % @ Please click the Browse button and select the SOL Backup file. ] KernN EI.
—® . SQL Backup Recovery
SQL Database Objects Select .BAK File: |

Select Temp File Path: CriUsersiaDMINI~1, TEX AppDataiLocali Temph

Select a recovery mode to recover SQL Backup Recovery

@ Standard Scan (Cuick Process, Recommended)

) Advanced Scan (Slow Proccess but preferred when "Out of Memory® message appears)

Select SQL database version
Auko detect database version { uncheck if vou want to select manually )
Manually select database wversion
0L Server 2000 database
0L Server 2005 database
S0L Server 2008, 2008 RZ database
QL Server 2012, 2014, 2016 ,2017 database

< Back [ Mext = ll Cancel b

Ready CAP| NUM| SCRL|
Figure 4.1 Home Screen

NOTE: "SQL Backup Recovery" dialog appears by-default when the software is launched. This dialog
can be launched by clicking the Add button in Tool bar or by selecting File menu > Add.

2. Click the Browse button to locate the corrupt SQL Backup file.
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- File Tools Help
L ﬂ « MAR... ¥ Kemel SQL bACKUP (ECOV.., v (| | SearchKernel SQLbACKUP .. R
E %‘ . _ T 5 | Kernel
—® . Organize v Newfolder Ey 1 @ SQL Backup Recovery
| sQu Database Objects A Name Date modified Type =
ﬁHumegroup | = — %
Omtec /608028 BAHe '
8 This pC
&Dskﬁup
,E] Documents
[R.E}own!oads
A Music
& Windows31 (C)
Dt (D)
Ul v
= e
i S W
R e s e e
Ready | cap{ NuM| SCR]
Figure 4.2 Browsing SQL Backup Files
3. Select the SQL backup file.
IKERNEL
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S0L Backup Recovery @

Pleaze click the Browse button and zelect the 5QL Backup File.

Select .BAK File: C:\Userstadministrator, texchl6)\Deskbop TESTOwith file group).bak.

Select Temp File Path:  Ci\Users|ADMINI~1, TEX}AppDatalLocall Temp) D

Select a recovery mode to recover SQL Backup Recovery

@) Standard Scan (Quick Process, Recommended)

) Advanced Scan (Slow Proccess but preferred when "Out of Memory" message appears)

Select SQL database version
Auto detect dakabase version { uncheck if wou want to select manually
Manually select database wersion
S0 Server 2000 database
S0 Server 2005 database
S0L Server 2008, 2008 R2 database
S0 Server 2012, 2014, 2016 ,2017 database

< Back Mext = ] I Cancel

Figure 4.3 Added SQL Backup File

4. Click the Next button to initiate the recovery process, Software will enlist the SQL backup objects in the
left pane.
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m Kemnel for SQL Backup Recovery

File Tools Help

E\ % ‘ @ Kernel
=@ J{} SQL Backup Recovery

-8 X

SQL Database Objects Obiject Script
271 TEST-FullDatabase Back 4
£ TEST(SOL Server 200

[]--Eﬁ Tables(2)
LTI User Data Types(
-TIG) Views(D)

15 Stored Procedure
Eﬁ Defaults(l
I Rules(l)

15 Triggens@)
Eﬁ Functions{l

-1 Syster Tables
-1 TEST-Full Filegroup Bacl

m

[]--Eﬁ Tables(d)
1) User Data Types(
I iews(l)
[J--Eﬁ Stored Procedure
Eﬁ Defaults{0)
Eﬁ Rules(l

I Triggers(D)

w5 Funrtinns(Th
1{ L[} I 1{

Ready

}

| cap| NUM] scri|

Figure 4.4 SQL Database Objects Added
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5. Select an object in the left tree whose content you want to verify before saving. When you select the

folder, its content will be displayed in the right pane.
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Kemel for SQL Backup Recavery _mx

File Tools Help

SH 0

‘k{} SQL Backup Recovery

SQL Database Objects A B : E
=+/VI(@ TEST-Full Database Back + | 1) i - m
=@ TESTISOL Server 200 |y .
2-L5) Tables(2)
-- dbo.Student
0[] dbo.T!
IG5 User Data Types(
LI Views(0)
Eﬁ Stored Procedure
- |5) Defaults(0)
|5 Rules(0)
I Triggers(l)
Eﬁ Functions({)

|5 Systern Tables
=L@ TEST-FullFlegroup Bacl

e TEST(SQU Server 200
5 Tablestd)

dbo.d3
dbo.Student
dba.sysdiagr:

: dbo.T!

..... [ 1lser Data Tunest ™ .
«m T Unp: 4 (1- 4) Records Frevious Records Pagel Mest Records Stap Refresh

—

it 44 5 ff
49 dd tr ee

mn

-

= | CAP| NUM SCRL| ¢

k

Figure 4.5 Previewing SQL Backup Database object

6. After previewing the required items, select the data for saving and then click the Save button. The 'Saving
Mode' dialog box appears.

[KERNEL
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File  Tools Help

=8

Y

1

Ready

SQL Database Objects

DB TEST-Full Database Back «

9|3 TEST-Full Filegroup Bal
S 719 TESTISOL Server 200

1 VIE Tablesis)
£V [E doo.d3
V55 Primary K
V5 Unique K
VI Constrain &
V155 Table Def
[]-- dbo.5tudent
[-]-- dbo.sysdiagr:
-V Primary K
-V Unique K
-G Constrain
[5G Table Def
£V =] dbo.T!
VI Primary K
-G Unique Ke
VI Constrain
V|5 Table Def
LIS Vser Data Tunes!

I }

Saving Mode
Please select the saving mode and click OK button
@) SQL Server
Server Namg  MNDRTI8-3HASHD Database Name  kernel

(7) Windaws Authentication

@ Server Authentication

User Mame  sa Password  sesssess

(7] Batch File

Sawing Falder

[ oK H Cancel I

To know more about this step, please click here

Brawse
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9 KerNEl

-V saL Backup Recovery

Figure 4.6 Saving SQL Backup data to Live SQL Server

;

| cAP| NUM| sCRL .

NOTE: To save the data you can click the Save button on the Tool bar or go to File menu > Save.

You can save the recovered objects in two different modes which are: SQL Server and Batch File. Select SQL

Server.

7. After selecting the required Saving mode option, click the OK button. The software starts saving the
recovered objects.
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File Tools Help

218 0

Kemel for SQL Backup Recovery

Kernel
wﬁ' SQL Backup Recovery

5QL Database Objects

G5 Tablest)

dbo.Student
-] dbo.T!

{TI5) User Data Types(

) Viewstl)

TI0) Stored Procedure

[0 Defaults(0)

0 Rules(l)

0I5 Triggens()

705 Functions()

i [005) Systern Tables

2-W1E TEST-Full Filegroup Bacl

-9 TESTSL Server 200

Ready

8. The software displays following 'Process Completed' dialog box when the data is saved successfully at the

SIS Tablestd

e dbo.d
9] dboStudent
Primaty K
Unigue ke
Constrain

w T dhn.ssdiann

1 3

desired location.

Student

Marks

Subjects

Tatal marks

-
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4(1- 4) Records

Raj
Sunil
Ram

faja

i
]
i
il

Please waitwhile the current process finishes.. E

H1
h1
h1
h1

Saving database ohiscts

%
5%
1%
0%

€

| Previous Records |

Pagel | MNewtRecords |

| Stop |

| Riefresh

Figure 4.8 Saving in Progress
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KerNel

8 SQL Backup Recovery

5QL Database Objects

=V TEST-Full Database Back +

| Bl TEST(OL Senver 200

5.5 Tablest?)
-- dbo.Student
i V[ dboT!

IG5 User Data Types

I iewsi)

IS Stored Procedurs

- Defaults()

U5 Rules(T)

LIS TriggersD)

- I5) Functions(D)

-l I System Tables
=] TEST-Full Filegroup Bacl

71 ® TESTISQL Server 200
25 Tablestd)

- [ dbot3

[V[=] dbo.Student

- dbosysdiagr

- @ VE dbol!

LTI Vser Diata Tunest ™
Al.m | b

m

-

Ready

9. Click the OK button to close the 'Process Completed' dialog box.

Process Cornpleted

Saving dane successfuly. .,

4 {1 - 4) Records

Figure 4.9 Saving Complete

Previouz Records

4.1.2 Restore to Batch File (by SQL Scripts)

Kernel SQL Backup Recovery is an ideal software that helps you restore objects from corrupt backups. No matter
what made your backup data corrupt or inaccessible, Kernel SQL backup recovery will recover your data easily
and quickly. Follow the steps given below to repair SQL backups:

Page 1

Mext Records

Stop Fefresh

| CAP| NUM| 5CRL|

1. Select Start > All Programs > Kernel SQL Backup Recovery > Kernel SQL Backup Recovery to launch the
software. The software home window appears.
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File

B B ®

Taals

Help

SQL Database Objects

Ready

2.

SOL Backup Recowvery

Please click the Browse button and select the SOL Backup file.
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) Kernel
' SQL Backup Recovery

Select .BAK File: |
Select Temp File Path: CiiUsersiADMIMNI-1, TEX AppDatalLocali Temph

Select a recovery mode to recover SQL Backup Recovery

@ Standard Scan (Cuick Process, Recommended)

) Advanced Scan (Slow Proccess but preferred when "Out of Memory® message appears)

Select SQL database version
Auko detect database version { uncheck if vou want to select manually )
Manually select database wversion
0L Server 2000 database
0L Server 2005 database
S0L Server 2008, 2008 RZ database
QL Server 2012, 2014, 2016 ,2017 database

e

< Back [ Mext = l[ Cancel

F

Figure 4.10 Home Screen

| CAP| NUM| 5CRL| .

NOTE: "SQL Backup Recovery" dialog appears by-default when the software is launched. This dialog
can be launched by clicking the Add button in Tool bar or by selecting File menu > Add.

Click the Browse button to locate the corrupt SQL Backup file.
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- File Tools Help
L ﬂ « MAR... ¥ Kemel SQL bACKUP (ECOV.., v (| | SearchKernel SQLbACKUP .. R
E %‘ . _ T 5 | Kernel
—® . Organize v Newfolder Ey 1 @ SQL Backup Recovery
| sQu Database Objects A Name Date modified Type =
ﬁHumegroup | = — %
Omtec /608028 BAHe '
8 This pC
&Dskﬁup
,E] Documents
[R.E}own!oads
A Music
& Windows31 (C)
Dt (D)
= e
i S W
R e s e e
Ready | cap{ NuM| SCR]
Figure 4.11 Browsing SQL Backup Files
3. Select the SQL backup file.
IKERNEL
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S0L Backup Recovery @

Pleaze click the Browse button and zelect the 5QL Backup File.

Select .BAK File: C:\Userstadministrator, texchl6)\Deskbop TESTOwith file group).bak.

Select Temp File Path:  Ci\Users|ADMINI~1, TEX}AppDatalLocall Temp) D

Select a recovery mode to recover SQL Backup Recovery

@) Standard Scan (Quick Process, Recommended)

) Advanced Scan (Slow Proccess but preferred when "Out of Memory" message appears)

Select SQL database version
Auto detect dakabase version { uncheck if wou want to select manually
Manually select database wersion
S0 Server 2000 database
S0 Server 2005 database
S0L Server 2008, 2008 R2 database
S0 Server 2012, 2014, 2016 ,2017 database

< Back Mext = ] I Cancel

Figure 4.12 Added SQL Backup File

4. Click the Next button to initiate the recovery process, Software will enlist the SQL backup objects in the
left pane.

IKERNEL Ad
KernelApps Private Limited umnscovmf



m Kernel for SQL Backup Recovery

File Tools Help

=B 0

Kernel

J{} SQL Backup Recovery

-8 X

SQL Database Objects Object Script
271 TEST-Full Database Back 4
£ TESTISQL Server 200

[]--Eﬁ Tables(?)
TIES) User Data Types(
-G Views(D)

-TIE Stored Procedure
Eﬁ Defaults(0)
TIE5) Rules(0)

-5 Triggens(D)
Eﬁ Functions(l)

[]--Eﬁ Systern Tables

m

[]--Eﬁ Tables(d)
10 User Data Types(
IS Views(0)
[J--Eﬁ Stored Procedure
Eﬁ Defaults{l)
Eﬁ Rules(l

TIE5) Triggers(l)

w15 Functinns(Th
1{ L[} I 1{

Ready

}

| cap| NUM| scRL|

Figure 4.13 SQL Database Objects Added
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5. Select an object in the left tree whose content you want to verify before saving. When you select the

folder, its content will be displayed in the right pane.
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Figure 4.14 Previewing SQL Backup Database object

6. After previewing the required items, select the data for saving and then click the Save button. The 'Saving
Mode' dialog box appears. You can save SQL backup data with Batch File mode (using SQL Script).
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Please select the saving mode and click OK button

O SQL Server
Server Mame  (Jlocal) Database Name
() Windows Authentication
(@) Server Authentication

User Mame =3

Saving Folder

ok || cancel

To know more about this step, please click here

Figure 4.15 Batch File Mode Saving Option

NOTE: To save the data you can click the Save button on the Tool bar or go to File menu > Save. |

You can save the recovered objects in two different modes which are: SQL Server and Batch File. Select SQL
Server.

7. Click the Browse button and select the destination path for saving SQL backup data. Finally click OK.
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Figure 4.16 Saving SQL Backup data to Batch File

8. The software starts saving the recovered objects.
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10. Click the OK button to close the 'Process Completed' dialog box.
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Using Batch File option, you can save the batch file of the rebuilt SQL backup file database on a desired location.

The data so recovered is saved in separate script files at the desired location. Also, a script file (commit.bat) is also

created that enables the user to easily copy the recovered objects to a new database created on SQL Server.

To copy recovered objects to new database on SQL server:

1. GotoSQL Server Management Studio

2. Create a New Database

3. Double click on commit.bat

OR
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(Run->cmd ) Change the path to recovered folder ( cd PathName)
4. Use following syntax:
>commit.bat servername newcreateddatabase sqglserverusername sqlserverpassword

Press Enter key and all tables will be copied to the new created database.

5. Conclusion

The Configuration Manual is handy to configure and use the program to restore SQL backup data from
corrupt/healthy files.

Learn more about the product and its benefits here: https://www.nucleustechnologies.com/sgl-backup-recovery/

6. Support

Connect to our experts immediately while facing any issues during installation, configuration, or associated

matters.

Product Experts Technical Gurus

USA/Canada: +1-800-814-0578 USA/Canada: +1-800-814-0578
UK/Europe: +44 (0) -845-594-3766 UK/Europe: +44(0)-800-088-5478

Rest of the World: +91 (0) -991-004-9028 Rest of the World: +91(0)-991-085-4291

Additionally, you can connect with us at https://www.nucleustechnologies.com/Contact.html to submit your

guery, or chat with one of our support team.
Moreover, you can write to us to the following email addresses:

e sales@nucleustechnologies.com (for Sales Queries)

e support@nucleustechnologies.com (for Support Queries)

7. Copyright

KernelApps Private Limited accompanied Installation & configuration manual, and documentation are
copyright of KernelApps Private Limited, with all rights reserved. Under the copyright laws, this user
manual cannot be reproduced in any form without the prior written permission of KernelApps Private
Limited. No Patent Liability is assumed, with respect to the use of the information contained herein.

© KernelApps Private Limited. All rights reserved.
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