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1. Introduction to Kernel for SharePoint Server 

Welcome to the user manual for Kernel for SharePoint Server, the most effective and outstanding recovery tool 
for MS SharePoint Server that recovers files from corrupt MDF database. This user manual comprises step by step 
guidelines on using Kernel for SharePoint Server. 

 

1.1. Using this Manual 

This user manual is intended to guide users on using Kernel for SharePoint Server. We suggest that first time 
users should read this user manual completely and carefully before proceeding to use the software. However, if 
you are an experienced user, you can use the table of contents to find out information pertaining to the tasks 
that you need to perform by using Kernel for SharePoint Server. You can use the table of contents to navigate 
through different sections of this user manual. The table of contents lists all the sections that are contained in this  
user manual in chronological order.  

 
1.1.1 List of Abbreviations 

 
Certain abbreviations have been used throughout this manual. For a clear understanding of the contents of this 
user manual, please go through the list of abbreviations, mentioned below, before reading the manual. 
 
MS: Microsoft 

 

RAM: Random Access Memory 

MB: Mega-Byte 

GB: Giga-Byte 

 

1.2. About Kernel for SharePoint Server 
Kernel for SharePoint Server is a database recovery software that extracts files and documents from the MS 
SharePoint Server database and enables users to access the important files once again. 

 

Kernel for SharePoint Server provides two repairing modes with which the MDF SharePoint databas e can be 
repaired online and offline; Raw File and Live SQL Instance. 

 

In Raw file mode, the user can repair the orphan MDF database and recover the documents. The Live SQL Instance 
mode benefits the user to get connected online to MS SharePoint Server, select the MDF database and perform 
the data recovery operation. 

 

Along with the two excellent modes, Kernel for SharePoint Server also facilitates users to test the SQL 



© KernelApps Private Limited 

  

 

Kernel for SharePoint Server         User Guide 

connections with UDL files and generate HTML reports for the recovered results. 
 

Use of Kernel for SharePoint Server becomes indispensable in the cases of: 
 

• Accurate and successful recovery of files from corrupt MDF database 
 

• Rebuilding of databases and uploading again to MS SharePoint Server 
 

• Document recovery when MDF database is corrupt and MS SharePoint Server is down 
 

• Access important shared files that have become inaccessible due to corruption of MDF database 
 

• Effortless and convenient extraction of files and folders from the corrupt database 
 

Kernel for SharePoint Server provides users with flawless and effortless document recovery and makes the 
corrupt files accessible once again. 
 

1.3. Salient Features 
 

Salient features of Kernel for SharePoint Server include: 
 

• Extract files from MDF Database that is corrupt by employing embedded recovery algorithm 
 

• All recovered files are restored in a new database, which is again configured on MS SharePoint Server 
 

• Maintains data integrity and security 
 

• Report creation options for checking recovery degree 
 

• Multiple recovery modes to perform recovery according to the requirement 
 

• User-friendly graphical user interface 
 

• Free evaluation version to analyze the capabilities of the tool before purchasing it 
 

 

1.4. Who Should Use This Software? 
Kernel for SharePoint Server is an apt solution for MS SharePoint database administrators to deal with MDF 
database corruption. MDF database that contains all files, folders and documents usually get corrupt and become 
inaccessible and hence, organizational workflow gets affected, as users are unable to access the important data 
and files. Kernel for SharePoint Server recovers files from MS SharePoint Server making the inaccessible 
documents accessible again. 

 

Some of the reasons which create the need for SharePoint Server Document Recovery software are: 
 

• Lost Document Libraries 
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• Accidental file deletion on WSS Websites 

• Server downtime and data inaccessibility due to drive failures 

• Failed backups/backups turn bad 
• Inaccessibility of server due to virus attacks or human errors 

 
 

1.5. How does Kernel for SharePoint Server Work? 
Organizations employ MS SharePoint Server with a motive to make collaborative activities easy; in fact, MS 
SharePoint Server as collaboration software meets all their expectations. MS SharePoint Server is outfitted with 
exclusive features for collaborative activities of any organization. As far as security is concerned, MS SharePoint 
Server provides any organization with an additional level of security and data integrity.  

But there are times when the database that contains SharePoint data or MS SharePoint Server or both get 
corrupt and in such a situation, an efficient and hi-tech data recovery solution is required. Kernel for SharePoint 
Server is an apt solution, which performs efficient recovery and extracts all files and folders from the corrupt 
database. Moreover, files that have been deleted through logical deletion can also be recovered with Kernel for 
SharePoint Server. Let us have a look at the process that Kernel for SharePoint Server follows for recovering files 
from corrupt MDF database: 

Normally, any requested data is processed via MS SharePoint Server and MS SQL Server. But in the case of 
SharePoint Server and MDF database corruption, the requested data becomes inaccessible. Kernel for SharePoint 
Server eliminates the dependency on MS SharePoint Server and enables the administrator to extract files from 
MDF Database that is corrupt. 

Kernel for SharePoint Server recovers files from the corrupt MDF database through establishing a connection 
with that database, which is stored in SQL Server. 

All recovered files are further restored in a new database and the database is again configured on MS SharePoint 
Server. 

 
 

 

2. Getting Started 
Now that you have understood the features and potential of Kernel for SharePoint Server, you are ready to get 
hands on experience of the software. To start the recovery process, you will first need to download  and install 
this software. However it is strongly recommended that before installing Kernel for SharePoint Server, you should 
go through the installation pre-requisites for the software to ensure that your computer is appropriately 
configured to run the software. 

 

2.1 Installation Pre-requisites 
The various pre-requisites for installing and running Kernel for SharePoint Server can be broadly classified into 
two major categories – Hardware requirements and Software requirements. 

2.1.1 Hardware Requirements: 
 

The hardware requirements for installing the software are as follows: 
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 You should have at-least 40 MB of free disk space if you want to  recover and save 40 MB 
.MDF files. 

 

• Pentium class processor 
 

• Minimum 64MB RAM (128 MB recommended) 
 

• 10MB for Software installation 
 

• Disk Space - Enough space to store the recovered files 
 

2.1.2 Software Requirements: 
 

The software requirements for installing the software are as follows: 

2.1.2.1 Operating System Requirements 

 

Supported operating systems: 
 

• Windows 10 
 

• Windows 8/8.1 
 

• Windows7 
 

• Windows Vista 
 

• Windows XP 
 

• Windows 2000 
 

2.1.2.2 MS SQL Servers Requirements 
 
Supported MS SQL server versions: 

• MS SQL Server 2000 
 

• MS SQL Server 2005 
 

• MS SQL Server 2008 
 

• MS SQL Server 2012 
 

• MS SQL Server 2014 
 

• MS SQL Server 2016 
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 You can recover and extract documents from SharePoint database by using the evaluation 
version of Kernel for SharePoint Server; however, the recovered files and folders will not be 
saved until you purchase the full version of the software. 

• MS SQL Server 2017 
 

• MS SQL Server 2019 
 

 

2.1.2.3 MS SharePoint Server Requirements 
   
Supported MS SharePoint server versions: 

• MS Office SharePoint Server 2007 
 

• MS Office SharePoint Server 2010 
 

• MS Office SharePoint Server 2013 
 

• MS Office SharePoint Server 2016 
 

• MS Office SharePoint Server 2019 
 
 

2.2 Downloading Kernel for SharePoint Server for the First Time 
 

After checking your computer for the prescribed system requirements for Kernel for SharePoint Server, you can 
download and install the software on your computer. 

 

If you want to try using Kernel for SharePoint Server before buying it, you can download the evaluation version 
from the following link: 
http://www.nucleustechnologies.com/download-sharepoint-document-recovery.html 
 

 

 
 

2.3 Install Kernel for SharePoint Server 
After downloading the installer file for Kernel for SharePoint Server, you can install the software by running the 
file. 

 

To install Kernel for SharePoint Server: 
 

1. Double-click the Kernel for SharePoint Server installer. 
 

2. Follow the on-screen instructions. 
 

The Setup Installation Complete screen will be displayed. 

http://www.nucleustechnologies.com/download-sharepoint-document-recovery.html
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 Before proceeding to uninstall Kernel for SharePoint Server, you must ensure that the 
software is not running in the system background. 

 

3. Click Finish to launch the software. 
 

 

2.4 Start Kernel for SharePoint Server 
To start Kernel for SharePoint Server: 

 

• Click the Start>All Programs>Kernel for SharePoint Server 
 

Alternatively, you can launch Kernel for SharePoint Server by double-clicking the shortcut icon available on the 
desktop and Quick Launch icon. 
 

2.5 Uninstall Kernel for SharePoint Server 
 

You may need to uninstall and re-install Kernel for SharePoint Server. To 

uninstall Kernel for SharePoint Server: 

1. Click the Start>All Programs>Kernel for SharePoint Server>Uninstall Kernel for SharePoint Server. A warning 
message will be displayed. 

 

2. Click ‘Yes’ to uninstall Kernel for SharePoint Server. 
 

 

You can alternatively uninstall Kernel for SharePoint Server from the Control Panel by performing the following 
steps: 

 

1. Click the Start Menu  Control Panel and then double click the Add or Remove Programs icon. 
 

2. Select Kernel for SharePoint Server and click Remove. 
 

A warning message will be displayed. 
 

3. Click ‘Yes’ to uninstall Kernel for SharePoint Server. 
 

3. Software Interface 
Now that Kernel for SharePoint Server has been installed on your computer, you can start using the software 
after getting acquainted with the software interface. 

 

3.1 Menu-bar 
 

The menu-bar of Kernel for SharePoint Server comprises two main menus – File and Help. 
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3.1.1 File Menu 
 

The File menu comprises three menu items. 

F igure: File Menu 

 

Menu items in the File menu: 
 

 
Field Name 

 
Field Description 

 
Open 

 
Select to open Database Source Selection window 

 

Save 
 

Select to save the selected files and folders 

 
Exit 

 
Select to close the software 

 
3.1.2 Help Menu 

 
The Help menu comprises three menu items: 

F igure: Help Menu 

 

Menu items in the Help menu: 
 

 
Field Name 

 
Field Description 

 
Software Help 

 
Select to view the user manual of Kernel for SharePoint Server 
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Software Homepage 
 

Select to go to the homepage of the software website 

 

About Kernel for SharePoint 
Server... 

 

Select to view version-related and support information of Kernel 
for SharePoint Server 

 

 

 

3.2 Tool-bar 
 

The tool-bar in Kernel for SharePoint Server is displayed below the menu-bar. The tool-bar provides a convenient 
and user-friendly method to perform certain actions that can also be performed by using the menu-bar. Read the 
information in the table below to find out about the tool-bar buttons: 

 
 
 

Button Button Name Button Description 

  
Open 

 
Opens the Database Source Selection window 

  

 
Save 

 

 
Saves the selected files and folders 

 

 
 

 
 

Help 

 
 

Opens the user manual of Kernel for SharePoint Server 
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3.3 Status Bar 
The Status bar is displayed at the bottom of the software window. The text ‘Ready’ is displayed on the status bar if 
Kernel for SharePoint Server is ready to be used. The Status bar also displays the text ‘CAP,’ ‘NUM,’ ‘SCRL’ which 
respectively correspond to the Caps Lock, Num Lock, and Scroll Lock keys on your keyboard. If any of these keys are 
pressed, the color of the corresponding text will turn blue/black.  

 
3.4 Left Panel  

F igure: Status Bar

Left Panel of Kernel for SharePoint Server displays recovered SharePoint folders and their subfolders in a hierarchical 
manner. Folders that are displayed at the left panel for Kernel for SharePoint Server are: 

 

• Tables 
 

• SharePoint 
 

• SharePoint Actual 
 

F igure: Left Panel 
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3.5 Right Panel 
Right Panel of Kernel for SharePoint Server displays the content of subfolders. The file information is 
displayed along with details like File Name, File Type, Version, Last Modified Time, Creation Time, and User 
name. 

 

F igure: Right Panel 

 If the recovery is done through Live SQL Instance, the left panel will display only SharePoint 
and SharePoint Actual folders. 
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 When Kernel for SharePoint Server is launched, the Source Selection window appears by 
default. You can also start the recovery process by selecting recovery mode from Source 
Selection Window. 

4. How to use Kernel for SharePoint Server? 
Now that you have a complete familiarity with the user interface of Kernel for SharePoint Server, you are ready to 
perform the SharePoint document recovery from the inaccessible SharePoint Server database. Kernel for SharePoint 
Server provides two modes of recovery: Raw File Mode and Live SQL Instance Mode. 

 

Raw Mode of recovery is used where only the MDF database is corrupt and MS SQL Server and MS SharePoint Server 
are in working condition. 

 

• This recovery mode is applicable in conditions where the database is corrupt. 
 

• In this recovery mode, the MDF database is repaired as an orphan file and items are extracted from it. 
 

• The use of the Orphan database in Raw mode eliminates the dependency of MS SharePoint Server in the 
recovery process. 

 

• Raw Mode recovers Tables, SharePoint, and Actual SharePoint folders and allows the user to view and save 
the files contained in those folders. 

 

• In Raw mode, tables can be recreated by connecting created batch file to the SQL Server Database; 
once the tables are recreated, the database is again ready to be configured in MS SharePoint Server. 

 

In cases where MS SharePoint Server is down or corrupt, Live SQL Instance recovery mode is used. This recovery 
mode is embedded with distinct features, which make it suitable for specified corruption conditions. Features of Live 
SQL Instance Mode are as follows: 

 

• This recovery mode is applicable in conditions where MS SharePoint Server is down. 
 

• In Live SQL Instance recovery mode, documents are extracted from the database. 
 

• Recovered documents can be again uploaded in a new account created on SharePoint Server. 
 

• UDL files connected to the SQL server can also be used for recovery. 
 

 

4.1 Recovery through Raw Mode 
 

With Raw mode, the recovery process can be performed by following these steps: 
 

1. Click Open from the toolbar or select Open from the File menu. 
 

 

2. A Source Selection window appears. Select Raw File mode and click ‘Next’. 
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F igure: Select the Database Source 

 

3. A new dialogue box – Select Database Location appears to select the database location.
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F igure: Select Database Location in Raw File Mode 

 

4. Click Browse and select the location where the corrupt MDF database is stored. Click Select T emp to select the 
location to save the temporary files which are generated by the software while performing various functions. 

 

5. Select the SQL file version and click Finish. The recovery process starts and a window showing the process status 
appears. 
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F igure: Scanning Process – Raw File Mode 

 

6. Once the recovery process is complete all the recovered Tables, SharePoint Actual, and SharePoint folders 
get listed at the left panel of the software. 

 

F igure: Preview Recovered Documents through Raw File mode 

 

7. Select folders you want to save from the left panel. 
 

8. Click Save on tool-bar or select File>Save from menu bar.  A dialogue box: Select Path for Saving appears, which 
asks for the saving location. 

 

9. Browse   for the location where you want to save the recovered files. 
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F igure: Select Path for Saving 

 

10. Select or de-select the Save in full path checkbox. This option, if checked saves the recovered files with a 
complete hierarchy of the table listed in the left panel, but if unchecked then the software only saves the 
respective folder with its contents. 

 

11. Click OK and files get saved in a defined location. 
 

 

4.2 Recovery through Live SQL Instance Mode 
In cases where MS SharePoint Server is down, Live SQL Instance Mode is used. To perform recovery through Live SQL 
Instance Mode, two options to connect with the database are available. 

 

These options are: 
 

• Connecting through SQL Server 
 

• Connecting through UDL File 
 

 

4.2.1 Connecting through SQL Server 
 

To perform recovery by connecting with the database through the MS SQL server, follow these simple steps: 
1. Click Open from the toolbar or select Open from the File menu. 
2. A new dialogue box - Select the Database Source will appear. Select Live SQL Instance mode and click ‘Next.’ 
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F igure: Select Database Source – Live SQL Instance 

 
3. Select Database Location window appears, which asks for server name, authentication and database name. Enter 

the details for the same and click Finish. 
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 Keep the Use UDL file for connection information option unchecked in this recovery process. 

 
F igure: Select Database Location – Live SQL Instance 

 

 

4. A window showing the status of the scanning process appears. 
 

F igure: Scanning and Recovery In Process 
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3. Once the recovery process is complete the recovered SharePoint Actual and SharePoint 
folders get listed at the left panel of the software. 

4. The next steps of saving are the same as steps 6 to 10 of the above-mentioned Recovery 
through Raw Mode. 

 

4.2.2 Connecting through UDL File 
Universal Data Link file (.udl) helps to specify connection information to a data provider on 
Windows 2000 and above operating systems. Kernel for SharePoint Server helps to achieve 
quick recovery of files by allowing them to get connected to the MS SQL Server through the 
UDL file and perform the recovery operation. 

 

To perform recovery by connecting the database through the UDL file, follow the given below steps: 
 

1. Click Open from the toolbar or select Open from the File menu. 
 

2. A new dialogue box - Select the Database Source will appear. Select Live SQL Instance mode 
and click ‘Next.’ 

 

3. For establishing a connection with the database from which files need to be recovered, 
enable Use UDL file for connection option on Database Location Selection dialogue box. 

 

F igure: Connecting through UDL File 

 

For connecting with the database with this option, you will need to create a UDL file 
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4.2.2.1 Creating a UDL file 

 

1. Create a New Text Document (.txt) at the desired location. 
 

2. Rename the file to ‘test.udl.’ 
 

3. Double click the ‘test.udl’. Data Link Properties dialogue box will appear. 
 

F igure: Data Link Properties – Provider tab 

 

4. In the Data Link Properties dialog box, click the Provider tab. 
 

5. Select the Provider that will be used to connect to your database. For example, if you 
need to check the availability of a Microsoft SQL database, you would need to select 
‘Microsoft OLE DB Provider for SQL Server.’ 

 

6. Select the appropriate option and click Next to continue to the C o nnection tab.  The 
Connection tab will request authentication information, which is used to access your 
database. 

 
 

 
 
 
 
 
 



© KernelApps Private Limited 

 

 

 You need to select the Allow saving password option for saving the password. If the password 
is not saved at the time of Data Link Properties configuration, the software fails to get 
connected with the database and a message regarding login failure appears on the Screen of 
Kernel for SharePoint Server. 

 
 
 
 
 
 

 
 

F igure: Data Link Properties – Connection tab 

 

 

7. Select or enter the Server name and the username and password used to access the 
database. 

 

 

8. Click the Test Connection button to confirm the connection to the server and database 
using the provided information. 

 

9. Open ‘test.udl’ with notepad. The file will contain a line with your connection string, 
which will be similar to: 

 

Provider=SQLOLEDB.1;Password=YourPassword;Persist Security Info=True;User 
ID=YourUserID;_Initial Catalog=YourDB;Data Source=YOUR_LOCAL_SERVER_NAME 

 

10. Once the UDL file is created, select Use UDL file for connection and browse the UDL file. 
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11. Click Finish. A window showing the status of the scanning process appears. 
 

12. Once the recovery process is complete the recovered SharePoint Actual and SharePoint 
folders get listed at the left panel of the software. 
 

13. The next steps of saving are the same as steps 6 to 10 of the above-mentioned Recovery 
through Raw Mode. 

 
 

5. Saving Recovered Data 
 
With Kernel for SharePoint Server recovered files can be saved very easily. Recovered files that are 
saved in any specified location are restored according to the mode used for performing the recovery 
process. Since Raw and Live SQL Instance recovery modes are used in specific corruption conditions, 
post-saving procedures for making the recovered files accessible again, are different. However, the 
process for saving recovered files is the same in both modes. 

 

To save recovered files, you need to follow these steps: 
 

1. Go to the left panel and select folders you want to save. 
2. Click Save on toolbar. 
3. A dialog box Select Path for Saving to select the saving path will appear. Type the location or 

Browse the location where you want to save the recovered files on your system. When you 
click Browse, a dialog box to browse the folder will appear. Select the folder or create a 
new folder to save selected files. 

 

F igure: Select Path for Saving 

 

4. Select or de-select the Save in full path checkbox. This option, if checked saves the 
recovered files with the complete hierarchy of the table listed in the left panel, but if 
unchecked then the software only saves the respective folder with its contents. 

5. Click OK and the files will be saved in a defined location. 
 

When using Raw Mode of recovery, Kernel for SharePoint Server generates a Commit.bat file 
that contains the recovered tables from the corrupt MDF file. The Commit.bat file is then easily 
attached and connected to the MS SQL Server and items from recovered tables are restored to 
a new database on the server. 

 
 

5.1 The process to restore from Commit.bat file 
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 This option is applicable when only the MDF database is corrupt and recovery is performed 
through Raw recovery mode. 

 

Follow the simple steps to create a new database. 

1. Go to SQL Server Management Studio. 
 

2. Create a New Database. 
 

3. Go to Command Prompt (Start menu->Run-> cmd ) 

4. Change the path to the recovered folder ( cd PathName ) 
 

5. Run the Commit.bat file by typing "commit.bat servername newcreateddatabase 
sqlserverusername sqlserverpassword" > press Enter key and all tables will be copied to 
the newly created database. 

 

6. Once all tables are copied in the database, the database is ready to be configured in 
MS SharePoint Server. 

 

5.2 Upload recovered files through Live SQL Instance 
 

 

When Live SQL Instance mode is used for recovery, SharePoint and SharePoint Actual folders 
are generated. These folders contain all the recovered files, which are further restored in a 
new account configured on MS SharePoint Server. Once a new account is created and 
configured on MS SharePoint Server, all files that are recovered through Kernel for SharePoint 
Server can be uploaded on that account. 

 

6. Creating and Saving Reports 
 

Kernel for SharePoint Server generates a list of path location where the files are positioned: 
SharePoint Folder Location and SharePoint Actual Folder Location. Report of extracted files and 
documents can also be saved with Kernel for SharePoint Server in HTML format. 

 

To save any report, the following steps need to be performed: 
 

1. At the bottom of the screen, a window titled Document List is displayed. This list contains 
fields such as File Name, SharePoint Folder Location and SharePoint Original Folder 
Location. 

 

To create a report click SharePoint folder location of the file for which you want to create report. 
 



© KernelApps Private Limited 

 

 

 Document List window also helps to filter or search for specific files and other items  if you 
know the saving location of those files. Search and click the appropriate link and locate the 
files. 

 Important: To view and hide the Document List window, right-mouse-click the Toolbar and 
check or uncheck the Document List option. 

F igure: Document List 

 
 
 
 
 

 

 

 

The report will get displayed at the right panel. The created report will contain fields like file 
name, file type, version, last modified time, created time and username. 

 

2. Select the relevant folder to save. 
 

3. Click Save on toolbar or go to the File menu and select Save. 
 

4. A dialogue box to select the saving path will appear. Browse the desired location, select folder 
and click OK. 

 
 

 
 

5. If you want to save list content in HTML file, click Save in HTML              option from the 
document list window. 

 

 

F igure: Show/Hide Document List 

 

 

6. A dialogue box to select the saving location will appear. Select the desired location and folder. 
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7.  Click OK and the report will be saved in HTML file. 
 

7. Troubleshooting 
 

This section deals with your generic and specific queries pertaining to using Kernel for SharePoint 
Server. 

 

7.1 Common Issues 
 

Why does Kernel for SharePoint Server have limitations in the evaluation copy? 
 

The free evaluation version of Kernel for SharePoint Server is intended to enable you to experience 
the capabilities of the software. You will need to buy the software to save the recovered files and 
folders. 
 

7.2 Frequently Asked Questions 
 

        How to Buy Kernel for SharePoint Server? 
 

You can buy Kernel for SharePoint Server online at 
https://www.nucleustechnologies.com/buy-sharepoint-document-recovery.html  

 

        I  have lost my full version for Kernel for SharePoint Server. Can you help me? 
 

         Please email us at sales@nucleustechnologies.com.  Please include your name, address, email 
address, and order confirmation number (if you have it). We will be happy to help you.  

 
 
 
 
 
 
 

https://www.nucleustechnologies.com/buy-sharepoint-document-recovery.html
mailto:sales@nucleustechnologies.com
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8. Conclusion 
 

     The User Guide is easy to understand and helps to recover data from corrupt and inaccessible MDF 
database files and restore it to SharePoint Server. Learn more about the product and its benefits 
here:  

     https://www.nucleustechnologies.com/sharepoint-document-recovery.html 
 

 

9. Support 
 

Connect to our experts immediately while facing any issues during installation, configuration, or 
associated matters: 

• 1-866-348-7872 

• 0-808-189-1438 
Additionally, you can connect with us at https://www.nucleustechnologies.com/Contact.html 
to submit your query, or chat with one of our support team. 
 
Moreover, you can write to us at the following email addresses: 

• sales@nucleustechnologies.com  (for Sales Queries) 

• support@nucleustechnologies.com  (for Support Queries) 
 

10. Copyright 
KernelApps Private Limited accompanied Installation & configuration manual, and 
documentation is copyright of KernelApps Private Limited, with all rights reserved. Under the 
copyright laws, this user manual cannot be reproduced in any form without the prior written 
permission of KernelApps Private Limited. No Patent Liability is assumed, with respect to the use 
of the information contained herein. 

© KernelApps Private Limited. All rights reserved. 
 

-end- 
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