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1. Introduction to Kernel Recovery for iPod 

1.1 Using this Manual 

Welcome to the User Guide of Kernel Recovery for iPod Software- an eminent and flawlessly 
designed iPod recovery software. This User Guide is intended to offer you a step-by-step guidance for 
performing iPod data recovery with the use of Kernel Recovery for iPod. Therefore, we suggest you to 
go through the user guide carefully before recovery vital iPod data with the use of Kernel Recovery for 
iPod. You can use Table of Contents for navigating through different segments of the User Guide for 
Kernel Recovery for iPod, as it contains all the topics present in the guide in a chronological order. 
Mentioned below are the topics discussed in the varied segments of this user guide: 

 Introduction to Kernel Recovery for iPod- Provides overview of Kernel Recovery for iPod 
software and key features. Also, mentioned here are the system requirements for installation 
of the software.   

 Getting Started- Offers details of installation and un-installation procedure of software  

 Understanding the User Interface- Explore user interface of Kernel Recovery for iPod 
Software. This section also lets you know about the menus and sub-menus for performing 
iPod music files recovery.  

 Perform iPod Recovery- Describes the process by which you can recover all the lost, deleted 
or inaccessible music files from your iPod using the software. 

 Purchase and Support- Provides information on free download, purchase and register issues. 
Offers solution to varied frequently asked questions during recovering data with the help of 
software.  

 Legal Notices- Provides information about copyright notices, trademarks, disclaimer, and 
license agreement related to Kernel Recovery for iPod software.  

We suggest experienced users to use table of contents to fetch information related to task they need 
to perform using the software.  

1.2 About Kernel Recovery for iPod 

Kernel Recovery for iPod software helps you to recover crucial music files, graphics, videos, 
documents and other contents of your iPod that have become corrupt, damaged or have been 
deleted from your iPod. Usually, crashes and corruption result in occurrence of error message on the 
screen of your iPod. You might have some problem in opening an image file, playing music files in 
iTunes or access you iPod. This software recovers damaged, deleted or lost data from your corrupt or 
crashed iPod in all cases of corruption. Some of the errors resolved by Kernel for iPod are: 

 "There was an error in the iTunes Store. Please try again later." 
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 "Firmware update failure" 

 "the iPod ** cannot be updated, the required folder cannot be found" 

 "Can't lock iPod. Please check if any other applications are using iPod and try again" 

 "iTunes folder cannot be found" 

 "Disk is locked" 

 "Unable to Check for Purchased Music because an error occurred (-5000 error)." 

Donôt get bothered with this situation that might seem to be hopeless to you, as a recovery solution 
will resolve all your worries away. Kernel Recovery for iPod is compatible for recovering data from all 
models of Apple iPod such as iPod Shuffle, iPod Nano, iPod Mini, iPod Touch, iPod Mini, Hard drive 
based, touch screen and video capable iPods etc. Being a user-friendly and efficient iPod data 
recovery tool, Kernel Recovery for iPod supports retrieving data lost due to virus attack, inappropriate 
handling of device, formatting and crashed iPod media, frozen iPod, sad face icon error, exclamation 
mark icon error or any other hardware malfunction. You can recover music files in any format 
including in MIDI, AIFF, M4A, OGG, RPS, M4P, AU, AVI, MOV, ASF, WMV, MP4, WMA, MP3, MPG, 
MPEG, GIF, WAV etc.  

1.3 Key Features 

Being comprehensive iPod recovery software, Kernel Recovery for iPod software is known for its 
accurate and assured results and excellent performance. Mentioned below are the key features of this 
software: 

Fast and accurate iPod data recovery- Recovers all files from your iPod which were either corrupt, 
lost, damaged or become inaccessible accurately and efficiently  

Comprehensive recovery- Performs comprehensive recovery and retrieves audio, video, sound 
files, image files, documents, folders and documents 

Recover all file formats- Recovery of a variety of file formats is possible including MIDI, AIFF, M4A, 
OGG, RPS, M4P, AU, AVI, MOV, ASF, WMV, MP4, WMA, MP3, MPG, MPEG, GIF, WAV etc 

Preserves data integrity- Ensures preservation of properties of data recovered from the iPod 
memory so that file becomes easily accessible.  

Powerful Recovery modes- Provides user with three robust recovery modes i.e. Standard, 
Advanced and Raw Scan to  

Resolves error messages- Resolves occurrence of error messages such as ñDisk is lockedò, ñiTunes 
folder cannot be foundò and ñFirmware update failure, Disk write errorò etc which often hamper 
smooth functioning of iPods 

Recovery in varied conditions- Typical iPod crash conditions such as virus invasion, improper 
device handling, hardware malfunctions, iPod update and iPod Reset (with iTunes software), 
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formatted and crashed iPod media, frozen iPod, Sad face icon error, Exclamation Mark icon error etc 
are easily dealt with this software.  

Supports all Apple iPod models- Software supports recovery from Apple iPod models such as iPod 
Shuffle, iPod Nano, iPod Mini, iPod Touch, iPod Mini, Hard drive based, touch screen and video 
capable iPods.  

Intuitive Graphical User Interface- Designed with interactive graphical user interface, user doesnôt 
need to have in-depth technical know-how to perform iPod data recovery 

Available as Free Evaluation Version- Available as free to evaluate version, you can experience the 
working, features and functioning of software without spending anything.  

1.4 System Requirements 

The various pre-requisites for installing and running Kernel Recovery for iPod can be broadly 
classified into two major categories ï Hardware requirements and Software requirements. 

1.4.1 Hardware Requirements:  

The hardware requirements for installing the software are as follows: 

 Pentium Class Processor 

 Minimum 64MB RAM (128 MB recommended) 

 10MB for Software installation 

 Disk Space - Enough space to store the repaired files 

@ You should have at-least 10 MB of free disk space if you want to repair and 
save a 10 MB.doc file. 

1.4.2 Software Requirements:  

The requirements are as follows: 

1.4.2.1 Operating System Requirements  

Supported operating systems: 

 Windows Vista 

 Windows XP 

 Windows 2003 

 Windows 2000 
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 Windows NT 

 Windows 98 

 Windows 95 

Supported iPods for Data Recovery: 

All Apple iPod models;  

 iPod Shuffle 

 iPod Nano 

 iPod Mini 

 iPod Touch 

 iPod Mini 

 Hard drive based, touch screen and video capable iPods
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2. Getting Started 

Now that you have understood the features and potential of Kernel Recovery for iPod, you are ready 
to get hands on experience of the software. To start repairing corrupt, damaged or lost iPod files, you 
will first need to download and install this software. 

It is strongly recommended that before installing Kernel Recovery for iPod, you should go through the 
installation pre-requisites for the software so that it can be assured that your computer is appropriately 
configured to run the software. 

2.1 Downloading Kernel Recovery for iPod for the First Time 

After checking your computer with the prescribed system requirements for Kernel Recovery for iPod, 
you can download and install the software on your computer. You can purchase the full version of the 
software from any one of our authorized resellersï Element5, Asknet and 2CO. 

If you want to try using Kernel Recovery for iPod before buying it, you can download the evaluation 
version from the following link: 

http://www.nucleustechnologies.com/ipod-data-recovery.html  

@ You can repair files saved on your iPod by using the evaluation version of 
Kernel Recovery for iPod; however, the repaired file will not be saved. To save 
the repaired music files you need to purchase the Full version of the software. 

2.2 Installing the Software 

After downloading the executable file for Kernel Recovery for iPod, you can install the software by 
running the file. To install Kernel Recovery for iPod: 

1. Double-click the setup exe file to open the Kernel Recovery for iPod Setup Wizard. Click the 
Next button 

2. On the Setup- Kernel Recovery for iPod screen, click the Next button  

3. Select the I accept the agreement option and click the Next button to continue  

4. Follow the on-screen instructions and select the location for installing the software etc. The 
setup install completion screen will be displayed. 

5.  Click the Finish button to exit setup. Main window of Kernel Recovery for iPod software will be 
launched. 

 

 

http://www.nucleustechnologies.com/ipod-data-recovery.html
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2.3 Uninstalling the Software 

You may need to uninstall and re-install Kernel Recovery for iPod. To uninstall Kernel Recovery for 
iPod: 

1. Click the Start Ą All Programs ĄKernel Recovery for iPod Ą Uninstall Kernel Recovery for 
iPod.  A warning message will be displayed. 

2. Click óYesô to uninstall Kernel Recovery for iPod. 

@ Before proceeding to uninstall Kernel Recovery for iPod, you must ensure that 
the software is not running. 

You can alternatively uninstall Kernel Recovery for iPod from the Control Panel by performing the 
following steps: 

1. Click the Start Menu Ą Control Panel and then double click the Add or Remove Programs icon. 

2.  Select Kernel Recovery for iPod and click Remove. A warning message will be displayed. 

3. Click óYesô to uninstall Kernel Recovery for iPod 
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3. Understanding the User Interface 

Now that Kernel Recovery for iPod has been installed on your computer, you can start using the 
software after getting acquainted with the software interface. 

3.1 Menu-bar 

The menu-bar of Kernel Recovery for iPod comprises four main menus ï Recovery, View, Tools, and 
Help. 

3.1.1 Recovery Menu 

The Recovery menu comprises four menu items. 

 

Figure 3.1: Recovery Menu 

Menu items in the Recovery menu: 

Field Name Field Description 

Recover Selected Select to recover and save the selected items 

Save Recovery Snapshot Select to save .KER file for the scanning process. 
iPod drive can be scanned and its snapshot can 
be saved with this option. Reload the saved .KER 
snapshot another time and save the re-scanning 
time of the drive.  

Load Recovery Snapshot Select to load the saved snapshot file (.KER) to 
Kernel Recovery for iPod. 

Exit Select to close the software 
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3.1.2 View Menu 

The View menu comprises three menu items. 

 

Figure 3.2: View Menu 

Menu Items in the View menu: 

Field Name Field Description 

Icons Select to view listed recovered files in Icons 
like view 

List Select to view listed recovered files in List like 
view  

Details Select to view listed recovered files in 
detailed view with complete information 

3.1.3 Tools Menu 

The Tools menu comprises five menu items. 

 

Figure 3.3: Tools Menu 

 Menu items in Tools menu: 

Field Name Field Description 
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Find Files Select to find specific file(s) from the 
recovered file(s) such as type *.gif and all gif 
files will get listed 

File Filters Select to filter the search process of file(s) 
amongst the recovered file (s) such as .mp3 
music files from hundreds of recovered files 

Settings Select to define settings for searching data, 
recovery and saving process  

Drive Information Select  to know information about the 
selected drive 

Live Update Select this option to update Kernel Recovery 
for iPod with the latest updated version if 
available online. 

 

3.1.4 Help Menu  

The Help menu comprises three menu items. 

 

Figure 3.4: Help Menu 

Menu items in the Help menu: 

Field Name Field Description 

Help Select this option to view Userôs Help Manual of 
Kernel Recovery for iPod  

Buy Online Select this option to purchase Kernel Recovery 
for iPod online  
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About Kernel Recovery for iPod Select this option to view support and version 
related information about Kernel Recovery for 
iPod 

3.2 Tool-bar 

The tool-bar in Kernel Recovery for iPod is displayed below the menu-bar. The tool-bar provides a 
convenient and user-friendly method to perform certain actions that can also be performed by using 
the menu-bar. Read the information in the table below to find out more details about the tool-bar 
buttons: 

Button Button Description 

 

Select to recover and save the selected files and folders 
listed by the software. 

 

Select to save snapshot of the scanned drive. The 
scanned process will be saved in .KER file  

 

Select to load the saved snapshot file (.KER) to Kernel 
Recovery for iPod  

 

Select to enter and search specific file types amongst 
thousands of file(s) thus recovered  

 

Select to define settings for Kernel Recovery for iPod 

 

Select to update Kernel Recovery for iPod with current 
version of the software available on Nucleus Data 
Recovery server 

 

Select to purchase Kernel Recovery for iPod online 
through Nucleus Data Recovery website 

 

Select to view the User's Help Manual of Kernel Recovery 
for iPod 
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4. Performing iPod Recovery 

Now that you have complete familiarity of the user interface of Kernel Recovery for iPod, you are 
ready to repair music files. Using Kernel Recovery for iPod, you can recover data from Logical device 
as well as Physical device: 

4.1 Logical Device Recovery 

Logical Device Recovery is performed on the partitions that are found by Kernel Recovery for iPod. All 
the Logical Devices found by the software are listed from where you can select the drive and perform 
the recovery process. Kernel Recovery for iPod offers three robust recovery modes for scanning the 
iPod and performing effective data recovery. You can select the mode according to the iPod 
corruption or condition that made the data in iPod inaccessible. All three recovery modes are 
described below:  

4.1.1 Standard Scan 

Standard Scan is a quick recovery mode that efficiently scans the selected iPod drive and retrieves 
recently deleted or lost files. Mentioned below is the step-by-step process for performing recovering 
data from iPod through Standard Scan: 

1. Select the Standard Scan option from the main window, following screen gets displayed: 
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Figure 4.1: Selected Drive Information for Standard Scan 

Select the drive that contains inaccessible data from the Logical Devices section in the left panel. 
The iPod recovery tool displays the drive information in the right panel; now click the Next button to 
continue the recovery operation 

2. Software will display information related to the selected iPod drive. Click the Next button to 
continue 

3. Kernel Recovery for iPod initiates the scanning process for the selected iPod drive, as shown 
below: 
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Figure 4.2: Scanning drive for Standard Scan 

@ Note: Click the Hide Progress button to hide or display the scanning process 

depicted at bottom of the window. 

After the software completes scanning, it displays the following message: 

 

Figure 4.3: Message for selecting Advance Scan 

Click OK to continue. 
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4. Software displays all the recovered files and folders in a tree-like structure. Select the file to check 
its preview before saving it: 

 

Figure 4.4: Display of recovered files 

The files which were deleted from the iPod and are now recovered with the software are displayed in 
Red color. Select the required folders and files that you want to save and click the Next button or 
Recover Selected button from the toolbar.  

5. Define a safe location for saving the recovered files. Software will start saving after you define the 
saving location: 
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Figure 4.5: Saving Process 

4.1.2 Advance Scan 

Advance Scan is more powerful but slow recovery mode from iPod drives. This scan mode enables 
successful data recovery from situations of frozen iPod, iPod displaying sad face or exclamation 
mark. This mode is slow in operation as compared to Standard Scan mode and scans the drive 
recursively to search for lost data. Mentioned below is the step-by-step process to perform iPod data 
recovery with the Advance Scan option: 

1. Select the Advance Scan option from the main window, following screen gets displayed: 
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Figure 4.6: Selected Drive information for Advance Scan  

Select the drive from the left panel for scanning and click the Next button to continue. 

2. Kernel Recovery for iPod displays comprehensive information about the selected drive. Click the 
Next button to continue the scanning process for the drive to locate file systems on drive.  


